How to Install Google Chrome 75 On RHEL/CentOS 7 and Fedora 30

Best Affordable Linux and WordPress Services For Your Business
Outsource Your Linux and WordPress Project and Get it Promptly Completed Remotely and Delivered Online.

If You Appreciate What We Do Here On TecMint, You Should Consider:

  1. Stay Connected to: Twitter | Facebook | Google Plus
  2. Subscribe to our email updates: Sign Up Now
  3. Get your own self-hosted blog with a Free Domain at ($3.45/month).
  4. Become a Supporter - Make a contribution via PayPal
  5. Support us by purchasing our premium books in PDF format.
  6. Support us by taking our online Linux courses

We are thankful for your never ending support.

Ravi Saive

I am Ravi Saive, creator of TecMint. A Computer Geek and Linux Guru who loves to share tricks and tips on Internet. Most Of My Servers runs on Open Source Platform called Linux. Follow Me: Twitter, Facebook and Google+

Your name can also be listed here. Got a tip? Submit it here to become an TecMint author.

RedHat RHCE and RHCSA Certification Book
Linux Foundation LFCS and LFCE Certification Preparation Guide

You may also like...

352 Responses

  1. shashank sharma says:

    Hey Google chrome not working in centos 7:

    Transaction Summary
    ======================================================================================================================================================
    Install  1 Package (+11 Dependent packages)
    
    Total size: 55 M
    Total download size: 926 k
    Installed size: 195 M
    Is this ok [y/d/N]: yes
    Downloading packages:
    
    
    Error downloading packages:
      redhat-lsb-core-4.1-27.el7.centos.1.x86_64: [Errno 256] No more mirrors to try.
      libappindicator-gtk3-12.10.0-13.el7.x86_64: [Errno 256] No more mirrors to try.
      1:liberation-narrow-fonts-1.07.2-16.el7.noarch: [Errno 256] No more mirrors to try.
      libdbusmenu-gtk3-16.04.0-4.el7.x86_64: [Errno 256] No more mirrors to try.
      libindicator-gtk3-12.10.1-6.el7.x86_64: [Errno 256] No more mirrors to try.
      libdbusmenu-16.04.0-4.el7.x86_64: [Errno 256] No more mirrors to try.
      patch-2.7.1-8.el7.x86_64: [Errno 256] No more mirrors to try.
      libXScrnSaver-1.2.2-6.1.el7.x86_64: [Errno 256] No more mirrors to try.
      spax-1.5.2-13.el7.x86_64: [Errno 256] No more mirrors to try.
      redhat-lsb-submod-security-4.1-27.el7.centos.1.x86_64: [Errno 256] No more mirrors to try.
      1:liberation-fonts-1.07.2-16.el7.noarch: [Errno 256] No more mirrors to try.
    
    • Ravi Saive says:

      @Shashank,

      Please enable the needed repositories correctly to install these dependency packages as shown.

      $ sudo yum clean all 
      $ sudo rm -r /var/cache/yum 
      $ sudo yum update 
      $ sudo yum install google-chrome-stable
      

      Also please install EPEL release.

      $ sudo yum install epel-release
      
  2. Cheung Wai Lam says:

    Question:

    My team in China have applied this Chrome version 69 to physical PC. The Chrome is able to be installed and open in this physical PC.

    However, this Chrome is able to be installed into a mini PC but can’t be open with the following message display:

    /usr/bin/google-chrome: symbol lookup error: /usr/bin/google-chrome: undefined symbol: gtk_widget_get_scale_factor

    This mini PC is configured with the following:

    • OS: CentOS Linux 7 (Core)
    • Processor: Pentium CPU J2900 @2.41GHz x 4
    • OS Type: 64 位
    • Graphic: Intel Bay Trail
    • GNOME: version 3.8.4
    • RAM: 3.6 GB
    • Storage: 28.3 GB

    Please see if there is anyone who may help to fix this problem? Thanks

    • Ravi Saive says:

      @Cheung,

      Try updating the system from the base repositories and it will fix this chrome error.

      # yum --disablerepo=\* --enablerepo=base,updates update
      

      and then reboot into 7.4 once it completes.

  3. raj says:

    Hello Sir / Madam

    Please help me to how to install VLC Player in RHEL7 OS

  4. Abdul says:

    Hi, can anyone please help me with the following error. I am trying to run Chrome 68 on RHEL 7.2.

    google-chrome --headless http://www.google.com
    
    [0827/152542.289445:ERROR:gpu_process_transport_factory.cc(1016)] Lost UI shared context.
    shared memfd open() failed: Invalid argument
    
  5. anji says:

    I am facing following error while running the Google Chrome.

    /bin/google-chrome: symbol lookup error: /bin/google-chrome: undefined symbol: gtk_style_context_set_scale

  6. Võ Quang Tuấn says:

    I installed Google Chrome to my CentOS VPS successfully, but when I run (via putty), it returns error: [1274:1274:0807/172204.994442:ERROR:zygote_host_impl_linux.cc(89)] Running as root without –no-sandbox is not supported. See https://crbug.com/638180.

    So, Pls help me to fix this error. Thank you.

    • Ravi Saive says:

      @Khai,

      Please don’t run Google chrome as root, try to run as normal system user…

      • Khai says:

        Dear Ravi Saive,

        Thank you for your response, but I still cannot start Google chrome when I remote to my VPS via Putty, Bitvise SSH. It returns error: “(google-chrome:2704): Gtk-WARNING **: cannot open display“.

        So, can I run Google chrome when I remote to VPS via Putty or Bitwise SSH?

        Thanks,
        Khai

        • Ravi Saive says:

          @Khai,

          That’s not possible bro, how can you run a Google chrome from a Putty without any GUI? Google chrome needs 1GB RAM with GUI support to run it..

        • Niall says:

          HI I am experiencing the exact same issue and im using non-root user. Did you get a fix for this? I tried X11forwarding: yes but and checked yum install for xauth and other suggested packages but they are all there. Running out of ideas with this.

      • chinmay says:

        add --no-sandbox option if running on root.

  7. phil says:

    Great post. Works like a charm! Up to date as welll

  8. Tesfa says:

    After installation when i tried to share it asks me to download and install chrome remote dektop host installer but unable to install it.

  9. Dragos Alexe says:

    Ravi , could you update the article to use GPG key from local file rather than allowing yum to retrieve the key from an external source?? It would be very helpful for me!!!
    Thanks!!!!!!

    • Ravi Saive says:

      @Dragos,

      If you don’t want to retrieve GPG key from external sources online, you can create your own GPG key using tools. Else you can download and install it locally as shown.

      # wget -q -O - https://dl.google.com/linux/linux_signing_key.pub
      
  10. jd says:

    I tried the steps you list to install chrome on fedora20-x86_74

    Did Not Work.

    fc20 needs an older release of chrome :(

    To wit:

    # yum install google-chrome-stable
    Loaded plugins: langpacks, refresh-packagekit
    google-chrome | 951 B 00:00:00
    Resolving Dependencies
    –> Running transaction check
    —> Package google-chrome-stable.x86_64 0:21.0.1180.89-154005 will be updated
    —> Package google-chrome-stable.x86_64 0:65.0.3325.181-1 will be an update
    –> Processing Dependency: libssl3.so(NSS_3.28)(64bit) for package: google-chrome-stable-65.0.3325.181-1.x86_64
    –> Processing Dependency: libnss3.so(NSS_3.22)(64bit) for package: google-chrome-stable-65.0.3325.181-1.x86_64
    –> Finished Dependency Resolution
    Error: Package: google-chrome-stable-65.0.3325.181-1.x86_64 (google-chrome)
    Requires: libssl3.so(NSS_3.28)(64bit)
    Error: Package: google-chrome-stable-65.0.3325.181-1.x86_64 (google-chrome)
    Requires: libnss3.so(NSS_3.22)(64bit)
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

Leave a Reply to Khai Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.