How to Create, Deploy and Launch Virtual Machines in OpenStack

If You Appreciate What We Do Here On TecMint, You Should Consider:

  1. Stay Connected to: Twitter | Facebook | Google Plus
  2. Subscribe to our email updates: Sign Up Now
  3. Use our Linode referral link if you plan to buy VPS (it starts at only $10/month).
  4. Support us via PayPal donate - Make a Donation
  5. Support us by purchasing our premium books in PDF format.
  6. Support us by taking our online Linux courses

We are thankful for your never ending support.

Matei Cezar

I'am a computer addicted guy, a fan of open source and linux based system software, have about 4 years experience with Linux distributions desktop, servers and bash scripting.

Your name can also be listed here. Got a tip? Submit it here to become an TecMint author.

RedHat RHCE and RHCSA Certification Book
Linux Foundation LFCS and LFCE Certification Preparation Guide

You may also like...

5 Responses

  1. sanya says:

    I am getting this error. [Error: No valid host was found. There are not enough hosts available.] What to do?

    • sanya says:

      While launching the instance.

    • Ravi Saive says:


      Please check with the following command that compute node as enabled and up.

      # nova service-list

      If its down, you need to restart the nova-compute service on the compute node and make sure that networking from controller to compute node configured properly. Can you able to ping controller node from compute node?

      Also make that libvirt is up on compute node.

  2. Matei Cezar says:

    Create external network with an administrative user.

  3. Carlos says:

    Hello, thanks for your tutorial, but i have only question, when we are selecting the network for the instances we must select the “external network” ? (Of course what i want to test is external access but when i select the external network on my log i can see a message like this ” ExternalNetworkAttachForbidden: It is not allowed to create an interface on external network “) but if i select internal net when i am creating the instance there is no error but i can’t access to my instance from lan :(

Got something to say? Join the discussion.

Your email address will not be published. Required fields are marked *

Join Over 300K+ Linux Users
  1. 177,942
  2. 8,310
  3. 37,548

Are you subscribed?