How to Enable EPEL Repository for RHEL/CentOS 7.x/6.x/5.x

If You Appreciate What We Do Here On TecMint, You Should Consider:

  1. Stay Connected to: Twitter | Facebook | Google Plus
  2. Subscribe to our email updates: Sign Up Now
  3. Get your own self-hosted blog with a Free Domain at ($3.45/month).
  4. Become a Supporter - Make a contribution via PayPal
  5. Support us by purchasing our premium books in PDF format.
  6. Support us by taking our online Linux courses

We are thankful for your never ending support.

Ravi Saive

I am Ravi Saive, creator of TecMint. A Computer Geek and Linux Guru who loves to share tricks and tips on Internet. Most Of My Servers runs on Open Source Platform called Linux. Follow Me: Twitter, Facebook and Google+

Your name can also be listed here. Got a tip? Submit it here to become an TecMint author.

RedHat RHCE and RHCSA Certification Book
Linux Foundation LFCS and LFCE Certification Preparation Guide

You may also like...

187 Responses

  1. Bhargav Talla says:

    Hi! All

    I am trying to Enable EPEL Repository in (_64 x86_64 x86_64 GNU/Linux)

    I am getting below erros please help me

    ThankQ

    # RHEL/CentOS 6 64-Bit ##

    # wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm

    # rpm -ivh epel-release-6-8.noarch.rpm

    [[email protected] Talla ~]# yum repolist

    Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
    Updating certificate-based repositories.
    Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

    [[email protected] Talla ~]#

    [[email protected] Talla ~]# yum –enablerepo=epel info zabbix

    Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
    Updating certificate-based repositories.
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again

    [[email protected] Talla ~]# yum –enablerepo=epel install zabbix

    Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
    Updating certificate-based repositories.
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again

    Note: The epel configuration file is located under /etc/yum.repos.d/epel.repo.

    • Ravi Saive says:

      First clear Yum cache as shown.

      # yum clean all && yum makecache
      

      You may come across such error, after installing epel-release. The quick fix is to update your SSL certificates:

      # yum -y upgrade ca-certificates
      
  2. thulasi says:

    I am having one doubt, in my interview interviewer asked that you configured yum server and you are having 3700 Packages in your local machine now you need to add extra 200 packages how?

    Please need help..

  3. Fury says:

    The centos6 link http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm does not seem to work. It might have been updated.

  4. RCD says:

    Centos 4 and Centos 5 are dead, you might want to remove references to them

    • Ravi Saive says:

      @Rene,

      I totally agree both CentOS 4 and CentOS 5 are dead, even epel repository don’t have any packages for it, all links are dead. And also I have updated the article by removing CentOS 5 and 4 links.

  5. prasun says:

    unable install openstack in rhel 7…
    got error while installing ( #yum install openstack-packstack) :
    Error: Package: 1:openstack-packstack-10.0.1-1.el7.noarch (openstack-ocata)
    Requires: python-docutils
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

    Kindly help …!!!!

  6. Naomi says:

    Hi,

    I got an error after issuing this command: yum –enablerepo=epel install phpmyadmin
    Could you help me please?

    Error: Package: php-tcpdf-6.2.13-1.el6.noarch (epel)
    Requires: php-posix
    Error: Package: php-tcpdf-6.2.13-1.el6.noarch (epel)
    Requires: php-bcmath
    Error: Package: php-tcpdf-6.2.13-1.el6.noarch (epel)
    Requires: php-tidy
    Error: Package: phpMyAdmin-4.0.10.19-1.el6.noarch (epel)
    Requires: php-mbstring
    Error: Package: php-php-gettext-1.0.12-1.el6.noarch (epel)
    Requires: php-mbstring
    Error: Package: php-tcpdf-6.2.13-1.el6.noarch (epel)
    Requires: php-mbstring
    You could try using –skip-broken to work around the problem
    ** Found 1 pre-existing rpmdb problem(s), ‘yum check’ output follows:
    SECU_PROD-2-1.i386 has missing requires of /usr/bin/sh

  7. Gaurav kumar says:

    Sir, I found error.

    This system is registered to Red Hat Subscription Management, but is not receiving updates. You can use subscription-manager to assign subscriptions.
    No package zabbix available.
    Error: Nothing to do

    what I do? please help me.

  8. Bhagyaraj says:

    Nice, i was trying for packages for RHEL 7, it worked well for me.
    Thank you Ravi Saive. Also thanks to other for queries it helps others too.

Got something to say? Join the discussion.

Your email address will not be published. Required fields are marked *