<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<link rel="profile" href="https://gmpg.org/xfn/11">
<title>How to Install Cacti on Rocky Linux and AlmaLinux</title>
<!-- All in One SEO 4.1.4.4 -->
<meta name="description" content="In this article, you will learn how to install and configure the Cacti network monitoring and graphing tool on Rocky Linux and AlmaLinux." />
<meta name="robots" content="max-image-preview:large" />
<meta name="google-site-verification" content="Lm2_CHFkgECZgEzZiN-gzDJYEF-xw7OMoGrpvemM-rs" />
<meta name="msvalidate.01" content="A92F4825ED7ABD97DAACAC1C05B9AF8E" />
<meta name="yandex-verification" content="327bf54006030f4a" />
<meta name="keywords" content="install cacti in rocky linux,install cacti in alma almalinux,install cacti in linux" />
<link rel="canonical" href="https://www.tecmint.com/install-cacti-on-rocky-linux-almalinux/" />
<!-- All in One SEO -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Tecmint: Linux Howtos, Tutorials &amp; Guides &raquo; Feed" href="https://www.tecmint.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Tecmint: Linux Howtos, Tutorials &amp; Guides &raquo; Comments Feed" href="https://www.tecmint.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Tecmint: Linux Howtos, Tutorials &amp; Guides &raquo; How to Install Cacti on Rocky Linux and AlmaLinux Comments Feed" href="https://www.tecmint.com/install-cacti-on-rocky-linux-almalinux/feed/" />
<link crossorigin="anonymous" rel='stylesheet' id='generate-fonts-css'  href='//fonts.googleapis.com/css?family=Muli:200,200italic,300,300italic,regular,italic,600,600italic,700,700italic,800,800italic,900,900italic|Nunito:200,200italic,300,300italic,regular,italic,600,600italic,700,700italic,800,800italic,900,900italic' type='text/css' media='all' />
<!-- <link rel='stylesheet' id='fancybox-style-css'  href='https://www.tecmint.com/wp-content/plugins/light/css/jquery.fancybox.css?ver=5.8.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='wp-show-posts-css'  href='https://www.tecmint.com/wp-content/plugins/wp-show-posts/css/wp-show-posts-min.css?ver=1.1.3' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='generate-style-css'  href='https://www.tecmint.com/wp-content/themes/tecmint/css/all.min.css?ver=2.4.2' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.tecmint.com/wp-content/cache/wpfc-minified/e75es2me/2lood.css" media="all"/>
<style id='generate-style-inline-css' type='text/css'>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</style>
<!-- <link rel='stylesheet' id='generate-child-css'  href='https://www.tecmint.com/wp-content/themes/tecmint_child/style.css?ver=1595914191' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='generate-secondary-nav-css'  href='https://www.tecmint.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style.min.css?ver=2.0.3' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.tecmint.com/wp-content/cache/wpfc-minified/qnfcpyr/2lood.css" media="all"/>
<style id='generate-secondary-nav-inline-css' type='text/css'>
.secondary-navigation{background-color:#0a1e48;}.secondary-navigation .top-bar{color:#ffffff;line-height:60px;font-family:"Nunito", sans-serif;font-weight:900;text-transform:none;font-size:15px;}.secondary-navigation .top-bar a{color:#ffffff;}.secondary-navigation .top-bar a:hover, .secondary-navigation .top-bar a:focus{color:#303030;}.secondary-navigation .main-nav ul li a,.secondary-navigation .menu-toggle,.secondary-menu-bar-items .menu-bar-item > a{color:#ffffff;font-family:"Nunito", sans-serif;font-weight:900;font-size:15px;line-height:60px;}.secondary-navigation .secondary-menu-bar-items{color:#ffffff;font-size:15px;}button.secondary-menu-toggle:hover,button.secondary-menu-toggle:focus{color:#ffffff;}.widget-area .secondary-navigation{margin-bottom:20px;}.secondary-navigation ul ul{background-color:#303030;top:auto;}.secondary-navigation .main-nav ul ul li a{color:#ffffff;font-size:14px;}.secondary-navigation .main-nav ul li:hover > a,.secondary-navigation .main-nav ul li:focus > a,.secondary-navigation .main-nav ul li.sfHover > a,.secondary-menu-bar-items .menu-bar-item:hover > a{color:#ff6060;background-color:#303030;}.secondary-navigation .main-nav ul ul li:hover > a,.secondary-navigation .main-nav ul ul li:focus > a,.secondary-navigation .main-nav ul ul li.sfHover > a{color:#ffffff;background-color:#474747;}.secondary-navigation .main-nav ul li[class*="current-menu-"] > a, .secondary-navigation .main-nav ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul li[class*="current-menu-"].sfHover > a{color:#f1c40f;background-color:#031230;}.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a,.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul ul li[class*="current-menu-"].sfHover > a{color:#ffffff;background-color:#474747;}@media (max-width:768px) {.secondary-menu-bar-items .menu-bar-item:hover > a{background: none;color: #ffffff;}}
</style>
<!-- <link rel='stylesheet' id='generate-secondary-nav-mobile-css'  href='https://www.tecmint.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style-mobile.min.css?ver=2.0.3' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.tecmint.com/wp-content/cache/wpfc-minified/g4dzjuqj/2lood.css" media="all"/>
<script src='//www.tecmint.com/wp-content/cache/wpfc-minified/fhgf5ep8/2lood.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://www.tecmint.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> -->
<!-- <script type='text/javascript' src='https://www.tecmint.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> -->
<link rel="https://api.w.org/" href="https://www.tecmint.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.tecmint.com/wp-json/wp/v2/posts/43934" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.tecmint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.tecmint.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.tecmint.com/?p=43934' />
<link rel="alternate" type="application/json+oembed" href="https://www.tecmint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tecmint.com%2Finstall-cacti-on-rocky-linux-almalinux%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.tecmint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tecmint.com%2Finstall-cacti-on-rocky-linux-almalinux%2F&#038;format=xml" />
<!-- Facebook Like Thumbnail (v0.4) -->
<meta property="og:image" content="https://www.tecmint.com/wp-content/uploads/2021/10/Install-Cacti-in-Rocky-Linux-and-AlmaLinux.png" />
<!-- using featured thumbnail -->
<!-- Facebook Like Thumbnail (By Ashfame - https://github.com/ashfame/facebook-like-thumbnail) -->
<meta name="viewport" content="width=device-width, initial-scale=1"><!-- Google Sitelinks Search Box -->    
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "WebSite",
"url": "https://www.tecmint.com/",
"potentialAction": {
"@type": "SearchAction",
"target": "https://www.tecmint.com/?q={search_term}",
"query-input": "required name=search_term"
}
}
</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-33207530-1"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-33207530-1');
</script>
<!-- PLACE THIS SECTION INSIDE OF YOUR HEAD TAGS -->
<script data-cfasync="false" type="text/javascript">
var freestar = freestar || {};
freestar.hitTime = Date.now();
freestar.queue = freestar.queue || [];
freestar.config = freestar.config || {};
freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;
freestar.config.enabled_slots = [];
!function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/tecmint-com";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
freestar.initCallback = function () { (freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false : freestar.newAdSlots(freestar.config.enabled_slots) }
</script>
<!-- PLACE THIS SECTION INSIDE OF YOUR BODY TAGS -->
<link rel="amphtml" href="https://www.tecmint.com/install-cacti-on-rocky-linux-almalinux/amp/"><link rel="icon" href="https://www.tecmint.com/wp-content/uploads/2020/07/favicon.ico" sizes="32x32" />
<link rel="icon" href="https://www.tecmint.com/wp-content/uploads/2020/07/favicon.ico" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.tecmint.com/wp-content/uploads/2020/07/favicon.ico" />
<meta name="msapplication-TileImage" content="https://www.tecmint.com/wp-content/uploads/2020/07/favicon.ico" />
<style type="text/css" id="wp-custom-css">
.alertbox {background-color: #edf7fe;border-left: 4px solid #bde2fb;display: block;padding: 10px;margin-bottom: 25px;}
.alertbox a {color:#bb0e30;text-decoration:underline;}
.entry-content p a:visited {
color: #c33;
}
</style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-43934 single-format-standard wp-custom-logo wp-embed-responsive post-image-above-header post-image-aligned-center secondary-nav-above-header secondary-nav-aligned-center right-sidebar nav-below-header fluid-header separate-containers active-footer-widgets-3 nav-search-enabled nav-aligned-center header-aligned-left dropdown-hover featured-image-active" itemtype="https://schema.org/Blog" itemscope>
<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>		<div class="top-bar top-bar-align-center">
<div class="inside-top-bar grid-container grid-parent">
<aside id="custom_html-3" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script language="JavaScript">
<!--
var r_text = new Array ();
r_text[0] = "<a target='_blank' rel='noopener noreferrer' href='https://www.tecmint.com/red-hat-rhcsa-rhce-exam-certification-book/'>RedHat RHCSA and RHCE Certification Preparation Guide</a> - <a class='button' href='https://www.tecmint.com/red-hat-rhcsa-rhce-exam-certification-book/' target='_blank' rel='noopener noreferrer'>Get This Book</a>";
r_text[1] = "<a target='_blank' rel='noopener noreferrer' href='https://www.tecmint.com/linux-foundation-lfcs-lfce-certification-exam-book/'>Linux Foundation LFCS and LFCE Certification Preparation Guide</a> - <a class='button orange' href='https://www.tecmint.com/linux-foundation-lfcs-lfce-certification-exam-book/' target='_blank' rel='noopener noreferrer'>Get This Book</a>";
r_text[2] = "<a target='_blank' rel='noopener noreferrer' href='https://www.tecmint.com/learn-linux-in-one-week/'>Learn Linux in One Week and Go From Zero to Hero</a> - <a class='button midnight-blue' href='https://www.tecmint.com/learn-linux-in-one-week/' target='_blank' rel='noopener noreferrer'>Get This Book</a>";
var i = Math.floor(3*Math.random())
document.write(r_text[i]);
//-->
</script></div></aside>			</div>
</div>
<nav id="secondary-navigation" class="secondary-navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope">
<div class="inside-navigation">
<button class="menu-toggle secondary-menu-toggle">
<span class="mobile-menu">Menu</span>					</button>
<div class="main-nav"><ul id="menu-home" class=" secondary-menu sf-menu"><li id="menu-item-334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-334"><a href="https://www.tecmint.com">Home</a></li>
<li id="menu-item-10774" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10774"><a target="_blank" rel="noopener" href="https://www.tecmint.com/who-we-are/">About</a></li>
<li id="menu-item-3912" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3912"><a title="Linux eBooks" target="_blank" rel="noopener" href="https://www.tecmint.com/linux-books-in-pdf-format/">eBooks</a></li>
<li id="menu-item-17151" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17151"><a title="Linux and Programming Online Courses" target="_blank" rel="noopener" href="https://deals.tecmint.com">Shop</a></li>
<li id="menu-item-18575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18575"><a title="Support Us" href="https://www.tecmint.com/donate-to-tecmint/">Donate</a></li>
<li id="menu-item-11736" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11736"><a target="_blank" rel="noopener" href="https://www.tecmint.com/linux-online-training-courses/">Linux Online Courses</a></li>
<li id="menu-item-11907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11907"><a title="Subscribe to TecMint Linux Updates" target="_blank" rel="noopener" href="https://www.tecmint.com/subscribe-to-blog/">Subscribe to Newsletter</a></li>
<li id="menu-item-13338" class="hosting menu-item menu-item-type-custom menu-item-object-custom menu-item-13338"><a title="Best Web Hosting Companies" target="_blank" rel="noopener" href="https://www.tecmint.com/best-web-hosting-for-linux/">Linux Hosting</a></li>
<li id="menu-item-24734" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24734"><a title="Linux Commands &#8211; A Beginners Cheat Sheet" target="_blank" rel="noopener" href="https://www.tecmint.com/linux-commands-cheat-sheet/">A-Z Linux Commands</a></li>
<li id="menu-item-38581" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-38581"><a target="_blank" rel="noopener">Get Involved<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-38583" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38583"><a target="_blank" rel="noopener" href="https://www.tecmint.com/testimonials/">Testimonials</a></li>
<li id="menu-item-38592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38592"><a target="_blank" rel="noopener" href="https://www.tecmint.com/submit-articles/">Join TecMint</a></li>
<li id="menu-item-38582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38582"><a target="_blank" rel="noopener" href="https://www.tecmint.com/submit-article-request/">Submit Article Request</a></li>
<li id="menu-item-38589" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38589"><a target="_blank" rel="noopener" href="https://www.tecmint.com/suggest-an-update/">Suggest an Update</a></li>
</ul>
</li>
</ul></div>				</div><!-- .inside-navigation -->
</nav><!-- #secondary-navigation -->
<header id="masthead" class="site-header" itemtype="https://schema.org/WPHeader" itemscope>
<div class="inside-header grid-container grid-parent">
<div class="header-widget">
<aside id="custom_html-2" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><!-- Tag ID: tecmint_leaderboard_atf -->
<div align="center" id="tecmint_leaderboard_atf">
<script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_leaderboard_atf", slotId: "tecmint_leaderboard_atf" });
</script>
</div></div></aside>			</div>
<div class="site-logo">
<a href="https://www.tecmint.com/" title="Tecmint: Linux Howtos, Tutorials &amp; Guides" rel="home">
<img  class="header-image" alt="Tecmint: Linux Howtos, Tutorials &amp; Guides" src="https://www.tecmint.com/wp-content/uploads/2020/07/logo.png" title="Tecmint: Linux Howtos, Tutorials &amp; Guides" />
</a>
</div>			</div><!-- .inside-header -->
</header><!-- #masthead -->
<nav id="site-navigation" class="main-navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope>
<div class="inside-navigation">
<form method="get" class="search-form navigation-search" action="https://www.tecmint.com/">
<input type="search" class="search-field" value="" name="s" title="Search" />
</form>		<div class="mobile-bar-items">
<span class="search-item">
<a aria-label="Open Search Bar" href="#">
</a>
</span>
</div><!-- .mobile-bar-items -->
<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="mobile-menu">Menu</span>				</button>
<div id="primary-menu" class="main-nav"><ul id="menu-header" class=" menu sf-menu"><li id="menu-item-10770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10770"><a href="https://www.tecmint.com/best-linux-distributions/">Linux Distro&#8217;s<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-42825" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42825"><a href="https://www.tecmint.com/centos-alternative-distributions/">CentOS Alternatives</a></li>
<li id="menu-item-40008" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40008"><a href="https://www.tecmint.com/linux-distro-for-power-users/">Best Linux Distros</a></li>
<li id="menu-item-40934" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40934"><a href="https://www.tecmint.com/redhat-based-linux-distributions/">RedHat Distributions</a></li>
<li id="menu-item-39889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39889"><a href="https://www.tecmint.com/best-linux-distributions-for-beginners/">Linux Distros for Beginners</a></li>
<li id="menu-item-39890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39890"><a href="https://www.tecmint.com/10-best-linux-server-distributions/">Linux Server Distros</a></li>
<li id="menu-item-39884" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39884"><a href="https://www.tecmint.com/debian-based-linux-distributions/">Debian Distributions</a></li>
<li id="menu-item-39885" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39885"><a href="https://www.tecmint.com/ubuntu-based-linux-distributions/">Ubuntu Distributions</a></li>
<li id="menu-item-39893" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39893"><a href="https://www.tecmint.com/arch-based-linux-distributions/">Arch Linux Distros</a></li>
<li id="menu-item-39886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39886"><a href="https://www.tecmint.com/best-rolling-release-linux-distributions/">Rolling Linux Distros</a></li>
<li id="menu-item-39887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39887"><a href="https://www.tecmint.com/best-linux-distributions-for-kde-plasma/">KDE Linux Distros</a></li>
<li id="menu-item-39892" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39892"><a href="https://www.tecmint.com/best-security-centric-linux-distributions/">Secure Linux Distros</a></li>
<li id="menu-item-39888" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39888"><a href="https://www.tecmint.com/linux-distributions-for-old-computers/">Linux Distros for Old PC</a></li>
<li id="menu-item-39891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39891"><a href="https://www.tecmint.com/new-linux-distributions/">New Linux Distros</a></li>
<li id="menu-item-39894" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39894"><a href="https://www.tecmint.com/best-linux-distributions-for-kids/">Linux Distros for Kids</a></li>
<li id="menu-item-39895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39895"><a href="https://www.tecmint.com/best-alternative-linux-distributions-for-windows-users/">Linux Distros for Windows Users</a></li>
</ul>
</li>
<li id="menu-item-10771" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10771"><a title="Linux Interview Questions" target="_blank" rel="noopener" href="https://www.tecmint.com/category/interview-questions/">FAQ&#8217;s</a></li>
<li id="menu-item-20869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-20869"><a href="https://www.tecmint.com/#">Programming<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-10772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10772"><a title="Learn Linux Shell Scripting" href="https://www.tecmint.com/category/bash-shell/">Shell Scripting</a></li>
<li id="menu-item-20870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20870"><a href="https://www.tecmint.com/category/python/">Learn Python</a></li>
<li id="menu-item-20871" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20871"><a href="https://www.tecmint.com/category/awk-command/">Learn Awk</a></li>
</ul>
</li>
<li id="menu-item-10773" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10773"><a href="https://www.tecmint.com/category/linux-commands/">Linux Commands</a></li>
<li id="menu-item-14795" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14795"><a href="https://www.tecmint.com/tag/linux-tricks/">Linux Tricks</a></li>
<li id="menu-item-19684" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19684"><a href="https://www.tecmint.com/category/top-tools/">Best Linux Tools</a></li>
<li id="menu-item-10443" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-10443"><a target="_blank" rel="noopener" href="https://www.tecmint.com/#">Certifications<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-14880" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14880"><a href="https://www.tecmint.com/how-to-setup-and-configure-static-network-routing-in-rhel/">RHCE Exam</a></li>
<li id="menu-item-11906" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11906"><a target="_blank" rel="noopener" href="https://www.tecmint.com/rhcsa-exam-reviewing-essential-commands-system-documentation/">RHCSA Exam</a></li>
<li id="menu-item-10444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10444"><a target="_blank" rel="noopener" href="https://www.tecmint.com/installing-network-services-and-configuring-services-at-system-boot/">LFCE Exam</a></li>
<li id="menu-item-14793" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14793"><a href="https://www.tecmint.com/sed-command-to-create-edit-and-manipulate-files-in-linux/">LFCS Exam</a></li>
<li id="menu-item-42469" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42469"><a title="LFCA Certification Guide" target="_blank" rel="noopener" href="https://www.tecmint.com/understanding-linux-operating-system/">LFCA Exam</a></li>
<li id="menu-item-34401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34401"><a title="Red Hat Ansible Exam Preparation Guide" target="_blank" rel="noopener" href="https://www.tecmint.com/understand-core-components-of-ansible/">Ansible Exam</a></li>
</ul>
</li>
<li id="menu-item-12399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-12399"><a href="https://www.tecmint.com/#">Guides<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-40716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40716"><a href="https://www.tecmint.com/best-practices-for-deploying-hadoop-server-on-centos/">Hadoop Series</a></li>
<li id="menu-item-18564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18564"><a target="_blank" rel="noopener" href="https://www.tecmint.com/install-docker-and-learn-containers-in-centos-rhel-7-6/">Docker Series</a></li>
<li id="menu-item-17150" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17150"><a href="https://www.tecmint.com/setup-postfix-mail-server-and-dovecot-with-mariadb-in-centos/">Postfix Mail</a></li>
<li id="menu-item-15041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15041"><a href="https://www.tecmint.com/citrix-xenserver-installation-and-network-configuration-in-linux/">XenServer Series</a></li>
<li id="menu-item-14794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14794"><a href="https://www.tecmint.com/install-redhat-virtualization-rhev/">RHEV Series</a></li>
<li id="menu-item-14805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14805"><a href="https://www.tecmint.com/what-is-clustering-and-advantages-disadvantages-of-clustering-in-linux/">Clustering Series</a></li>
<li id="menu-item-12400" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12400"><a href="https://www.tecmint.com/create-lvm-storage-in-linux/">LVM Series</a></li>
<li id="menu-item-12402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12402"><a href="https://www.tecmint.com/understanding-raid-setup-in-linux/">RAID Series</a></li>
<li id="menu-item-12403" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12403"><a href="https://www.tecmint.com/install-and-configure-kvm-in-linux/">KVM Series</a></li>
<li id="menu-item-12401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12401"><a href="https://www.tecmint.com/create-centralized-secure-storage-using-iscsi-targetin-linux/">iSCSI Series</a></li>
<li id="menu-item-12406" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12406"><a href="https://www.tecmint.com/install-zentyal-as-primary-domain-controller-and-integrate-windows-system/">Zentyal Series</a></li>
<li id="menu-item-16084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16084"><a href="https://www.tecmint.com/install-and-configure-ansible-automation-tool-in-linux/">Ansible Series</a></li>
<li id="menu-item-16395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16395"><a href="https://www.tecmint.com/install-and-configure-django-web-framework-in-centos-debian-ubuntu/">Django Series</a></li>
<li id="menu-item-14603" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14603"><a href="https://www.tecmint.com/create-gui-applications-in-linux/">Create GUI Apps</a></li>
</ul>
</li>
<li id="menu-item-14796" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-14796"><a href="https://www.tecmint.com/command-line-tools-to-monitor-linux-performance/">Monitoring Tools<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-14797" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14797"><a href="https://www.tecmint.com/install-nagios-in-linux/">Nagios</a></li>
<li id="menu-item-14798" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14798"><a href="https://www.tecmint.com/install-and-configure-zabbix-monitoring-on-debian-centos-rhel/">Zabbix</a></li>
<li id="menu-item-14799" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14799"><a href="https://www.tecmint.com/install-cacti-network-monitoring-on-rhel-centos-6-3-5-8-and-fedora-17-12/">Cacti</a></li>
<li id="menu-item-14800" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14800"><a href="https://www.tecmint.com/install-observium-in-centos/">Observium</a></li>
<li id="menu-item-14801" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14801"><a href="https://www.tecmint.com/monitorix-a-lightweight-system-and-network-monitoring-tool-for-linux/">Monitorix</a></li>
<li id="menu-item-14802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14802"><a href="https://www.tecmint.com/install-collectd-and-collectd-web-to-monitor-server-resources-in-linux/">Collectd</a></li>
<li id="menu-item-14803" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14803"><a href="https://www.tecmint.com/linux-performance-monitoring-with-collectl-tool/">Collectl</a></li>
<li id="menu-item-14804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14804"><a href="https://www.tecmint.com/mysql-performance-monitoring/">MySQL Monitoring</a></li>
</ul>
</li>
<li class="search-item"><a aria-label="Open Search Bar" href="#"></a></li></ul></div>			</div><!-- .inside-navigation -->
</nav><!-- #site-navigation -->
<div id="page" class="hfeed site grid-container container grid-parent">
<div id="content" class="site-content">
<div id="primary" class="content-area grid-parent mobile-grid-100 grid-75 tablet-grid-75">
<main id="main" class="site-main">
<article id="post-43934" class="post-43934 post type-post status-publish format-standard has-post-thumbnail hentry category-almalinux category-monitoring-tools category-rocky-linux" itemtype="https://schema.org/CreativeWork" itemscope>
<div class="inside-article">
<header class="entry-header">
<h1 class="entry-title" itemprop="headline">How to Install Cacti on Rocky Linux and AlmaLinux</h1>			<div class="entry-meta">
<span class="byline"><span class="author vcard" itemtype="http://schema.org/Person" itemscope="itemscope" itemprop="author"><a href="https://www.tecmint.com/author/james2030kiarie/" title="View all posts by James Kiarie" rel="author"><span class="author-name" itemprop="name">James Kiarie</span></a></span></span><span class="posted-on"><time class="updated" datetime="2021-10-06T11:37:58+05:30" itemprop="dateModified">October 6, 2021</time><time class="entry-date published" datetime="2021-10-06T11:37:47+05:30" itemprop="datePublished">October 6, 2021</time> </span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.tecmint.com/category/almalinux/" rel="category tag">AlmaLinux</a>, <a href="https://www.tecmint.com/category/monitoring-tools/" rel="category tag">Monitoring Tools</a>, <a href="https://www.tecmint.com/category/rocky-linux/" rel="category tag">Rocky Linux</a></span> <span class="comments-link"><a href="https://www.tecmint.com/install-cacti-on-rocky-linux-almalinux/#respond">Leave a comment</a></span> 			</div><!-- .entry-meta -->
<center style="padding-bottom:20px;padding-top:40px;">
<!-- Tag ID: tecmint_leaderboard_article_top -->
<div align="center" id="tecmint_leaderboard_article_top">
<script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_leaderboard_article_top", slotId: "tecmint_leaderboard_article_top" });
</script>
</div>
</center>
</header><!-- .entry-header -->
<div class="entry-content" itemprop="text">
<p><strong>Cacti</strong> is an open-source web-based network monitoring and graphing tool written in PHP. It was designed as a front-end application for data logging using RRDtool. Cacti uses the SNMP protocol to monitor devices such as routers, servers, and switches.</p>
<p>It displays information such as network bandwidth utilization and CPU load in a graph format. It’s essential in monitoring and ensuring IT infrastructure is functioning as desired.</p>
<p><strong>[ You might also like: <a title="Linux Bandwidth Monitoring Tools" href="https://www.tecmint.com/linux-network-bandwidth-monitoring-tools/" target="_blank" rel="noopener">16 Useful Bandwidth Monitoring Tools to Analyze Network Usage in Linux</a> ]</strong></p>
<p>In this guide, you will learn how to install the <strong>Cacti</strong> monitoring tool on <strong>Rocky Linux</strong> and <strong>AlmaLinux</strong>.</p>
<h3>Step 1: Install Apache Web Server</h3>
<p><strong>Cacti</strong> is a web-based tool, so we must set up a web server on which <strong>Cacti</strong> will run. Run the following command to install an <strong>Apache</strong> webserver:</p>
<pre>$ sudo dnf install httpd -y
</pre>
<center style="padding-bottom: 45px;padding-top:35px;"><div align="center" id="tecmint_incontent"><script data-cfasync="false" type="text/javascript">freestar.config.enabled_slots.push({ placementName: "tecmint_incontent", slotId: "tecmint_incontent" });</script></div></center><p>Next, start and enable the webserver with the commands:</p>
<pre>$ sudo systemctl start httpd
$ sudo systemctl enable --now httpd
</pre>
<h3>Step 2: Install MariaDB Database Server</h3>
<p><strong>Cacti</strong> require its own database to store the data it collects. We will install and use <strong>Mariadb</strong> as our database server.</p>
<pre>$ sudo dnf install -y mariadb-server mariadb
</pre>
<p>Next, start and enable mariadb to start on boot as shown:</p>
<pre>$ sudo systemctl start mariadb
$ sudo systemctl enable mariadb
</pre>
<h3>Step 3: Install PHP and PHP Extensions</h3>
<p><strong>Cacti</strong> is written in <strong>PHP</strong>, and therefore, we need to install <strong>PHP</strong> and the required PHP dependencies. First, add the Remi repository:</p>
<pre>$ sudo dnf install dnf-utils http://rpms.remirepo.net/enterprise/remi-release-8.rpmmi 
</pre>
<p>Then, enable the <strong>DNF</strong> module for <strong>PHP</strong> installation.</p>
<pre>$ sudo dnf module reset php
$ sudo dnf module enable php:remi-7.4
</pre>
<p>After that, install <strong>PHP</strong> and required extensions with the commands below:</p>
<pre>$ sudo dnf install @php
$ sudo dnf install -y php php-{mysqlnd,curl,gd,intl,pear,recode,ldap,xmlrpc,snmp,mbstring,gettext,gmp,json,xml,common}
</pre>
<p>Enable the <strong>php-fpm</strong> service by executing the command:</p>
<pre>$ sudo systemctl enable --now php-fpm
</pre>
<h3>Step 4: Install SNMP and RRD Tool</h3>
<p>Now we will install <strong>SNMP</strong> and <strong>RRDtool</strong>, which are required for gathering and analyzing system metrics.</p>
<pre>$ sudo dnf install -y net-snmp net-snmp-utils net-snmp-libs rrdtool
</pre>
<p>Start and enable snmpd with the commands:</p>
<pre>$ sudo systemctl start snmpd
$ sudo systemctl enable snmpd
</pre>
<h3>Step 5: Create a Cacti Database</h3>
<p>We now need to create a database and user for <strong>cacti</strong> and grant all the necessary privileges to the cacti user.</p>
<pre>$ mysql -u root -p

<strong>MariaDB [(none)]&gt;</strong> CREATE DATABASE cactidb;
<strong>MariaDB [(none)]&gt;</strong> GRANT ALL ON cactidb.* TO <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="ef8c8e8c9b86b09a9c8a9daf83808c8e8387809c9b">[email&#160;protected]</a> IDENTIFIED  BY 'passwd123';
<strong>MariaDB [(none)]&gt;</strong> FLUSH PRIVILEGES;
<strong>MariaDB [(none)]&gt;</strong> EXIT;
</pre>
<figure id="attachment_43935" aria-describedby="caption-attachment-43935" style="width: 833px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Create-Cacti-Database.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Create-Cacti-Database.png" loading="lazy" class="size-full wp-image-43935" alt="Create Cacti Database" width="843" height="272" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Create-Cacti-Database.png 843w, https://www.tecmint.com/wp-content/uploads/2021/10/Create-Cacti-Database-768x248.png 768w" sizes="(max-width: 843px) 100vw, 843px"><noscript><img loading="lazy" class="size-full wp-image-43935" src="https://www.tecmint.com/wp-content/uploads/2021/10/Create-Cacti-Database.png" alt="Create Cacti Database" width="843" height="272" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Create-Cacti-Database.png 843w, https://www.tecmint.com/wp-content/uploads/2021/10/Create-Cacti-Database-768x248.png 768w" sizes="(max-width: 843px) 100vw, 843px" /></noscript></a><figcaption id="caption-attachment-43935" class="wp-caption-text">Create Cacti Database</figcaption></figure>
<p>Then, import the mysql test data <strong>timezone.sql</strong> file into the mysql database.</p>
<pre>$ mysql -u root -p mysql &lt; /usr/share/mariadb/mysql_test_data_timezone.sql
</pre>
<p>Then, connect to the mysql database and provide the cacti user access to the <strong>mysql.time</strong> zone name table.</p>
<pre><strong>MariaDB [(none)]&gt;</strong> GRANT SELECT ON mysql.time_zone_name TO <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="55363436213c0a2026302715393a3634393d3a2621">[email&#160;protected]</a>;
<strong>MariaDB [(none)]&gt;</strong> FLUSH PRIVILEGES;
<strong>MariaDB [(none)]&gt;</strong> EXIT;
</pre>
<figure id="attachment_43936" aria-describedby="caption-attachment-43936" style="width: 816px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Import-Cacti-Database.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Import-Cacti-Database.png" loading="lazy" class="size-full wp-image-43936" alt="Import Cacti Database" width="826" height="263" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Import-Cacti-Database.png 826w, https://www.tecmint.com/wp-content/uploads/2021/10/Import-Cacti-Database-768x245.png 768w" sizes="(max-width: 826px) 100vw, 826px"><noscript><img loading="lazy" class="size-full wp-image-43936" src="https://www.tecmint.com/wp-content/uploads/2021/10/Import-Cacti-Database.png" alt="Import Cacti Database" width="826" height="263" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Import-Cacti-Database.png 826w, https://www.tecmint.com/wp-content/uploads/2021/10/Import-Cacti-Database-768x245.png 768w" sizes="(max-width: 826px) 100vw, 826px" /></noscript></a><figcaption id="caption-attachment-43936" class="wp-caption-text">Import Cacti Database</figcaption></figure>
<p>For optimal performance, you need to add the following configuration in the <strong>mariadb-server.cnf</strong> file under the <code>[ mysqld ]</code> section as shown.</p>
<pre>$ sudo vi /etc/my.cnf.d/mariadb-server.cnf
</pre>
<p>Paste the following configuration.</p>
<pre>collation-server=utf8mb4_unicode_ci
character-set-server=utf8mb4
max_heap_table_size=32M
tmp_table_size=32M
join_buffer_size=64M
# 25% Of Total System Memory
innodb_buffer_pool_size=1GB
# pool_size/128 for less than 1GB of memory
innodb_buffer_pool_instances=10
innodb_flush_log_at_timeout=3
innodb_read_io_threads=32
innodb_write_io_threads=16
innodb_io_capacity=5000
innodb_file_format=Barracuda
innodb_large_prefix=1
innodb_io_capacity_max=10000
</pre>
<p>Save the changes and exit.</p>
<h3>Step 6: Installing and Configuring the Cacti Monitoring Tool</h3>
<p>The <strong>Cacti</strong> package is available in the <strong>EPEL</strong> (<strong>Extra Packages for Enterprise Linux</strong>) repository.</p>
<pre>$ sudo dnf install epel-release -y
</pre>
<p>Next, we install the <strong>Cacti</strong> monitoring tool as shown:</p>
<pre>$ sudo dnf install cacti -y
</pre>
<p>Next, verify the installation of <strong>cacti</strong> as shown:</p>
<pre>$ rpm -qi cacti
</pre>
<figure id="attachment_43937" aria-describedby="caption-attachment-43937" style="width: 814px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Verify-Cacti-Installation.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Verify-Cacti-Installation.png" loading="lazy" class="size-full wp-image-43937" alt="Verify Cacti Installation" width="824" height="450" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Verify-Cacti-Installation.png 824w, https://www.tecmint.com/wp-content/uploads/2021/10/Verify-Cacti-Installation-768x419.png 768w" sizes="(max-width: 824px) 100vw, 824px"><noscript><img loading="lazy" class="size-full wp-image-43937" src="https://www.tecmint.com/wp-content/uploads/2021/10/Verify-Cacti-Installation.png" alt="Verify Cacti Installation" width="824" height="450" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Verify-Cacti-Installation.png 824w, https://www.tecmint.com/wp-content/uploads/2021/10/Verify-Cacti-Installation-768x419.png 768w" sizes="(max-width: 824px) 100vw, 824px" /></noscript></a><figcaption id="caption-attachment-43937" class="wp-caption-text">Verify Cacti Installation</figcaption></figure>
<p>Then, import the default cacti database tables into the mariadb cacti database you created above. But before that, run the following command to determine the path of the default cacti database:</p>
<pre>$ rpm -ql cacti | grep cacti.sql
</pre>
<figure id="attachment_43938" aria-describedby="caption-attachment-43938" style="width: 673px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Locate-Cacti-Database.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Locate-Cacti-Database.png" loading="lazy" class="size-full wp-image-43938" alt="Locate Cacti Database" width="683" height="75"><noscript><img loading="lazy" class="size-full wp-image-43938" src="https://www.tecmint.com/wp-content/uploads/2021/10/Locate-Cacti-Database.png" alt="Locate Cacti Database" width="683" height="75" /></noscript></a><figcaption id="caption-attachment-43938" class="wp-caption-text">Locate Cacti Database</figcaption></figure>
<p>Next, use the following command to import the default database tables:</p>
<pre>$ mysql -u root -p cactidb &lt; /usr/share/doc/cacti/cacti.sql
</pre>
<p>Next, modify the cacti configuration file to include the following database details:</p>
<pre>$ sudo vim /usr/share/cacti/include/config.php
</pre>
<figure id="attachment_43939" aria-describedby="caption-attachment-43939" style="width: 713px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Configure-Cacti-Database.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Configure-Cacti-Database.png" loading="lazy" class="size-full wp-image-43939" alt="Configure Cacti Database" width="723" height="176"><noscript><img loading="lazy" class="size-full wp-image-43939" src="https://www.tecmint.com/wp-content/uploads/2021/10/Configure-Cacti-Database.png" alt="Configure Cacti Database" width="723" height="176" /></noscript></a><figcaption id="caption-attachment-43939" class="wp-caption-text">Configure Cacti Database</figcaption></figure>
<p>Modify the database name, username, and password to reflect the one you created earlier.</p>
<p>Next, set the timezone in the <strong>php.ini</strong> file. Additionally, modify the below parameters to reflect as shown:</p>
<pre>date.timezone = Africa/Nairobi
memory_limit = 512M
max_execution_style = 60
</pre>
<p>Then, set up cron for Cacti by editing the <strong>/etc/cron.d/cacti</strong> file as shown:</p>
<pre>$ sudo vim /etc/cron.d/cacti
</pre>
<p>Uncomment the following line to have a Cacti poll for data every 5 minutes.</p>
<pre>*/5 * * * *   apache /usr/bin/php /usr/share/cacti/poller.php &gt; /dev/null 2&gt;&amp;1
</pre>
<p>Save and exit the configuration file.</p>
<p>Then modify Apache’s configuration file to enable remote access to Cacti.</p>
<pre>$ sudo vim /etc/httpd/conf.d/cacti.conf
</pre>
<p>Change the following lines in the file:</p>
<figure id="attachment_43940" aria-describedby="caption-attachment-43940" style="width: 852px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Enable-Cacti-Remote-Access.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Enable-Cacti-Remote-Access.png" loading="lazy" class="size-full wp-image-43940" alt="Enable Cacti Remote Access" width="862" height="430" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Enable-Cacti-Remote-Access.png 862w, https://www.tecmint.com/wp-content/uploads/2021/10/Enable-Cacti-Remote-Access-768x383.png 768w" sizes="(max-width: 862px) 100vw, 862px"><noscript><img loading="lazy" class="size-full wp-image-43940" src="https://www.tecmint.com/wp-content/uploads/2021/10/Enable-Cacti-Remote-Access.png" alt="Enable Cacti Remote Access" width="862" height="430" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Enable-Cacti-Remote-Access.png 862w, https://www.tecmint.com/wp-content/uploads/2021/10/Enable-Cacti-Remote-Access-768x383.png 768w" sizes="(max-width: 862px) 100vw, 862px" /></noscript></a><figcaption id="caption-attachment-43940" class="wp-caption-text">Enable Cacti Remote Access</figcaption></figure>
<ul>
<li>Modify <strong>Require host localhost</strong> to <strong>Require all granted</strong>.</li>
<li>Change <strong>Allow from localhost</strong> to <strong>Allow from [network subnet]</strong>.</li>
<li>Specify your own network subnet. For our case, the subnet is <strong>192.168.122.1/24</strong>.</li>
</ul>
<p>Restart apache and php-fpm services for the changes to take effect.</p>
<pre>$ sudo systemctl restart httpd
$ sudo systemctl restart php-fpm
</pre>
<p>Before finally setting up <strong>Cacti</strong>, allow <strong>HTTP</strong> service on your firewall as shown:</p>
<pre>$ sudo firewall-cmd --permanent --add-service=http
$ sudo firewall-cmd --reload
</pre>
<h3>Step 8: Running Cacti Installer via the Browser</h3>
<p>To complete the set up of <strong>Cacti</strong>, visit your server’s IP as shown:</p>
<pre>http://server-ip/cacti
</pre>
<p>The login page shown below will appear. Log in with the default credentials shown:</p>
<pre>Username: admin
Password: admin
</pre>
<p>Click &#8216;<strong>Login</strong>&#8216; to proceed.</p>
<figure id="attachment_43941" aria-describedby="caption-attachment-43941" style="width: 1230px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Login.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Login.png" loading="lazy" class="size-full wp-image-43941" alt="Cacti Login" width="1240" height="525" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Login.png 1240w, https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Login-768x325.png 768w" sizes="(max-width: 1240px) 100vw, 1240px"><noscript><img loading="lazy" class="size-full wp-image-43941" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Login.png" alt="Cacti Login" width="1240" height="525" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Login.png 1240w, https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Login-768x325.png 768w" sizes="(max-width: 1240px) 100vw, 1240px" /></noscript></a><figcaption id="caption-attachment-43941" class="wp-caption-text">Cacti Login</figcaption></figure>
<p>You will be asked to set the default cacti admin login password.</p>
<figure id="attachment_43942" aria-describedby="caption-attachment-43942" style="width: 1121px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Change-Cacti-Admin-Password.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Change-Cacti-Admin-Password.png" loading="lazy" class="size-full wp-image-43942" alt="Change Cacti Admin Password" width="1131" height="507" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Change-Cacti-Admin-Password.png 1131w, https://www.tecmint.com/wp-content/uploads/2021/10/Change-Cacti-Admin-Password-768x344.png 768w" sizes="(max-width: 1131px) 100vw, 1131px"><noscript><img loading="lazy" class="size-full wp-image-43942" src="https://www.tecmint.com/wp-content/uploads/2021/10/Change-Cacti-Admin-Password.png" alt="Change Cacti Admin Password" width="1131" height="507" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Change-Cacti-Admin-Password.png 1131w, https://www.tecmint.com/wp-content/uploads/2021/10/Change-Cacti-Admin-Password-768x344.png 768w" sizes="(max-width: 1131px) 100vw, 1131px" /></noscript></a><figcaption id="caption-attachment-43942" class="wp-caption-text">Change Cacti Admin Password</figcaption></figure>
<p>Next, Accept the GPL license agreement and click on &#8216;<strong>Begin</strong>&#8216;.</p>
<figure id="attachment_43943" aria-describedby="caption-attachment-43943" style="width: 592px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Agreement.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Agreement.png" loading="lazy" class="size-full wp-image-43943" alt="Cacti Agreement" width="602" height="339"><noscript><img loading="lazy" class="size-full wp-image-43943" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Agreement.png" alt="Cacti Agreement" width="602" height="339" /></noscript></a><figcaption id="caption-attachment-43943" class="wp-caption-text">Cacti Agreement</figcaption></figure>
<p><strong>Cacti</strong> will run pre-installation tests to ensure that the necessary <strong>PHP</strong> modules are installed and the relevant database settings are set up. If everything is configured correctly, you can proceed with the installation. Click <strong>Next</strong> to proceed.</p>
<figure id="attachment_43944" aria-describedby="caption-attachment-43944" style="width: 756px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Pre-Installation-Check.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Pre-Installation-Check.png" loading="lazy" class="size-full wp-image-43944" alt="Cacti Pre-Installation Check" width="766" height="380"><noscript><img loading="lazy" class="size-full wp-image-43944" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Pre-Installation-Check.png" alt="Cacti Pre-Installation Check" width="766" height="380" /></noscript></a><figcaption id="caption-attachment-43944" class="wp-caption-text">Cacti Pre-Installation Check</figcaption></figure>
<p>After that, choose the &#8216;<strong>New Primary Server</strong>&#8216; as the type of installation and verify that the database connection parameters are right.</p>
<figure id="attachment_43945" aria-describedby="caption-attachment-43945" style="width: 757px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Installation-Type.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Installation-Type.png" loading="lazy" class="size-full wp-image-43945" alt="Cacti Installation Type" width="767" height="381"><noscript><img loading="lazy" class="size-full wp-image-43945" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Installation-Type.png" alt="Cacti Installation Type" width="767" height="381" /></noscript></a><figcaption id="caption-attachment-43945" class="wp-caption-text">Cacti Installation Type</figcaption></figure>
<p>The following step checks for directory issues and confirms that the proper permissions are in place. If everything is in order, click &#8216;<strong>Next</strong>&#8216;; otherwise, click ‘<strong>Previous</strong>&#8216; and correct any problems.</p>
<figure id="attachment_43946" aria-describedby="caption-attachment-43946" style="width: 1119px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Permission-Check.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Permission-Check.png" loading="lazy" class="size-full wp-image-43946" alt="Cacti Permission Check" width="1129" height="564" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Permission-Check.png 1129w, https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Permission-Check-768x384.png 768w" sizes="(max-width: 1129px) 100vw, 1129px"><noscript><img loading="lazy" class="size-full wp-image-43946" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Permission-Check.png" alt="Cacti Permission Check" width="1129" height="564" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Permission-Check.png 1129w, https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Permission-Check-768x384.png 768w" sizes="(max-width: 1129px) 100vw, 1129px" /></noscript></a><figcaption id="caption-attachment-43946" class="wp-caption-text">Cacti Permission Check</figcaption></figure>
<p>The installer then checks to see if all of the binary paths for the required packages are installed.</p>
<figure id="attachment_43947" aria-describedby="caption-attachment-43947" style="width: 586px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Binary-Checks.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Binary-Checks.png" loading="lazy" class="size-full wp-image-43947" alt="Cacti Binary Checks" width="596" height="264"><noscript><img loading="lazy" class="size-full wp-image-43947" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Binary-Checks.png" alt="Cacti Binary Checks" width="596" height="264" /></noscript></a><figcaption id="caption-attachment-43947" class="wp-caption-text">Cacti Binary Checks</figcaption></figure>
<p>Next, we validate data input methods. This gives you a few actions to take after installing <strong>Cacti</strong> in order to whitelist data input methods. Check the ‘<strong>I have read this statement</strong>&#8216; box after reading the instructions.</p>
<figure id="attachment_43948" aria-describedby="caption-attachment-43948" style="width: 608px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Validation-Whitelist-Protection.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Validation-Whitelist-Protection.png" loading="lazy" class="size-full wp-image-43948" alt="Cacti Validation Whitelist Protection" width="618" height="270"><noscript><img loading="lazy" class="size-full wp-image-43948" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Validation-Whitelist-Protection.png" alt="Cacti Validation Whitelist Protection" width="618" height="270" /></noscript></a><figcaption id="caption-attachment-43948" class="wp-caption-text">Cacti Validation Whitelist Protection</figcaption></figure>
<p>Thereafter, choose the cron interval and input your network subnet as shown. Then click &#8216;<strong>Next</strong>&#8216;.</p>
<figure id="attachment_43949" aria-describedby="caption-attachment-43949" style="width: 639px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Network-Settings.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Network-Settings.png" loading="lazy" class="size-full wp-image-43949" alt="Cacti Network Settings" width="649" height="300"><noscript><img loading="lazy" class="size-full wp-image-43949" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Network-Settings.png" alt="Cacti Network Settings" width="649" height="300" /></noscript></a><figcaption id="caption-attachment-43949" class="wp-caption-text">Cacti Network Settings</figcaption></figure>
<p><strong>Cacti</strong> come with templates that let you monitor and graph a variety of network devices, including Linux and Windows computers. All options have been checked to ensure that you get all of the templates you need. If you&#8217;re satisfied, click &#8216;<strong>Next</strong>&#8216;.</p>
<figure id="attachment_43950" aria-describedby="caption-attachment-43950" style="width: 495px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Templates.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Templates.png" loading="lazy" class="size-full wp-image-43950" alt="Cacti Templates" width="505" height="365"><noscript><img loading="lazy" class="size-full wp-image-43950" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Templates.png" alt="Cacti Templates" width="505" height="365" /></noscript></a><figcaption id="caption-attachment-43950" class="wp-caption-text">Cacti Templates</figcaption></figure>
<p>Following that, the installer will verify to see if the database/server collation is UTF8 compliant. Click the ‘<strong>Next</strong>&#8216; button.</p>
<figure id="attachment_43951" aria-describedby="caption-attachment-43951" style="width: 494px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-UTF8.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-UTF8.png" loading="lazy" class="size-full wp-image-43951" alt="Cacti UTF8" width="504" height="225"><noscript><img loading="lazy" class="size-full wp-image-43951" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-UTF8.png" alt="Cacti UTF8" width="504" height="225" /></noscript></a><figcaption id="caption-attachment-43951" class="wp-caption-text">Cacti UTF8</figcaption></figure>
<p>To start the installation process, click on the &#8216;<strong>Confirm Installation</strong>&#8216; checkbox and then click on the &#8216;<strong>Install</strong>&#8216; button.</p>
<figure id="attachment_43952" aria-describedby="caption-attachment-43952" style="width: 513px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Installation.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Installation.png" loading="lazy" class="size-full wp-image-43952" alt="Cacti Installation" width="523" height="173"><noscript><img loading="lazy" class="size-full wp-image-43952" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Installation.png" alt="Cacti Installation" width="523" height="173" /></noscript></a><figcaption id="caption-attachment-43952" class="wp-caption-text">Cacti Installation</figcaption></figure>
<p>Once the necessary packages have been installed, click the &#8216;<strong>Get Started</strong>&#8216; button.</p>
<figure id="attachment_43953" aria-describedby="caption-attachment-43953" style="width: 602px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Installation-Complete.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Installation-Complete.png" loading="lazy" class="size-full wp-image-43953" alt="Cacti Installation Complete" width="612" height="282"><noscript><img loading="lazy" class="size-full wp-image-43953" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Installation-Complete.png" alt="Cacti Installation Complete" width="612" height="282" /></noscript></a><figcaption id="caption-attachment-43953" class="wp-caption-text">Cacti Installation Complete</figcaption></figure>
<p>Now the <strong>Cacti</strong> dashboard will be displayed as shown:</p>
<figure id="attachment_43954" aria-describedby="caption-attachment-43954" style="width: 653px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Dashboard.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Dashboard.png" loading="lazy" class="size-full wp-image-43954" alt="Cacti Dashboard" width="663" height="368"><noscript><img loading="lazy" class="size-full wp-image-43954" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Dashboard.png" alt="Cacti Dashboard" width="663" height="368" /></noscript></a><figcaption id="caption-attachment-43954" class="wp-caption-text">Cacti Dashboard</figcaption></figure>
<p>By default, cacti create resource utilization graphs for your local machine on which Cacti is installed. To view the graphs, navigate through &#8211; Graph &#8211;&gt; Default Tree &#8211;&gt; Local &#8211;&gt; Choose Your Device.</p>
<figure id="attachment_43955" aria-describedby="caption-attachment-43955" style="width: 790px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Linux-Server-Monitoring.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Linux-Server-Monitoring.png" loading="lazy" class="size-full wp-image-43955" alt="Cacti Linux Server Monitoring" width="800" height="369" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Linux-Server-Monitoring.png 800w, https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Linux-Server-Monitoring-768x354.png 768w" sizes="(max-width: 800px) 100vw, 800px"><noscript><img loading="lazy" class="size-full wp-image-43955" src="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Linux-Server-Monitoring.png" alt="Cacti Linux Server Monitoring" width="800" height="369" srcset="https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Linux-Server-Monitoring.png 800w, https://www.tecmint.com/wp-content/uploads/2021/10/Cacti-Linux-Server-Monitoring-768x354.png 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></a><figcaption id="caption-attachment-43955" class="wp-caption-text">Cacti Linux Server Monitoring</figcaption></figure>
<p>That&#8217;s how you install <strong>Cacti</strong> on <strong>Rocky Linux</strong> and <strong>AlmaLinux</strong>.</p>
</div><!-- .entry-content -->
<footer class="entry-meta">
<nav id="nav-below" class="post-navigation">
<span class="screen-reader-text">Post navigation</span>
<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.tecmint.com/install-tightvnc-access-remote-desktop-in-linux/" rel="prev">How to Install TightVNC to Access Remote Desktops in Linux</a></span></div>		</nav><!-- #nav-below -->
</footer><!-- .entry-meta -->
<div class="alertbox">If you liked this article, then do <a style="text-decoration:underline;color:bb0e30;" rel="nofollow" target="_blank" href="https://newsletter.tecmint.com/subscription?f=hj6Ohm9gck3Z0PQ2BBBTh892iaCbDV3jJJa3hD8ULUlubOgnbo8aF44vt2HZfdc36g">subscribe to email alerts</a> for Linux tutorials. If you have any questions or doubts? do <a style="text-decoration:underline;color:bb0e30;" href="https://www.tecmint.com/install-cacti-on-rocky-linux-almalinux/#respond">ask for help in the comments</a> section.</div>
<center style="padding-bottom:20px;padding-top:40px;">
<!-- Tag ID: tecmint_incontent_2 -->
<div align="center" id="tecmint_incontent_2">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_incontent_2", slotId: "tecmint_incontent_2" });
</script>
</div>
</center>
<div class="after-post-box">
<h2>If You Appreciate What We Do Here On TecMint, You Should Consider:</h2>
<p>TecMint is the fastest growing and most trusted community site for any kind of Linux Articles, Guides and Books on the web. Millions of people visit TecMint! to search or browse the thousands of published articles available FREELY to all.</p>
<p>If you like what you are reading, please consider buying us a coffee ( or 2 ) as a token of appreciation.</p>
<p align="center"><a href="https://www.buymeacoffee.com/tecmint" rel="nofollow" target="_blank"><img alt="Support Us" src="https://www.tecmint.com/wp-content/uploads/2015/01/coffee.png" alt="Coffee"></a></p>
<p style="text-align: center;"><strong style=" color:#fe3300;font-size:20px;">We are thankful for your never ending support.</strong></p>
</div>
<div class="wpsp-related-posts  grid-container">
<h2>Related Posts</h2>
<style>.wp-show-posts-columns#wpsp-38213 {margin-left: -2em; }.wp-show-posts-columns#wpsp-38213 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-38213" class=" wp-show-posts-columns wp-show-posts" style=""><article class=" wp-show-posts-single post-43900 post type-post status-publish format-standard has-post-thumbnail hentry category-almalinux category-rocky-linux wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/install-magento-on-rocky-linux-and-almalinux/"  title="How to Install Magento on Rocky Linux and AlmaLinux"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-Magento-in-Rocky-Linux.png" width="720" height="340" class="attachment-full size-full wp-post-image" alt="Install Magento in Rocky Linux" loading="lazy" itemprop="image"><noscript><img width="720" height="340" src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-Magento-in-Rocky-Linux.png" class="attachment-full size-full wp-post-image" alt="Install Magento in Rocky Linux" loading="lazy" itemprop="image" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/install-magento-on-rocky-linux-and-almalinux/" rel="bookmark">How to Install Magento on Rocky Linux and AlmaLinux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-43887 post type-post status-publish format-standard has-post-thumbnail hentry category-almalinux category-monitoring-tools category-nagios category-rocky-linux wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/install-nagios-in-rocky-linux-and-almalinux/"  title="How to Install Nagios Core in Rocky LInux and AlmaLinux"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-Nagios-Core-in-Linux.png" width="720" height="340" class="attachment-full size-full wp-post-image" alt="Install Nagios in Linux" loading="lazy" itemprop="image"><noscript><img width="720" height="340" src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-Nagios-Core-in-Linux.png" class="attachment-full size-full wp-post-image" alt="Install Nagios in Linux" loading="lazy" itemprop="image" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/install-nagios-in-rocky-linux-and-almalinux/" rel="bookmark">How to Install Nagios Core in Rocky LInux and AlmaLinux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-43870 post type-post status-publish format-standard has-post-thumbnail hentry category-almalinux category-centos category-mssql category-redhat category-rocky-linux wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/install-microsoft-sql-server-in-linux/"  title="How to Install SQL Server in RHEL, Rocky Linux and AlmaLinux"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-MS-SQL-Server-on-Linux.png" width="720" height="340" class="attachment-full size-full wp-post-image" alt="Install MS SQL Server on Linux" loading="lazy" itemprop="image"><noscript><img width="720" height="340" src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-MS-SQL-Server-on-Linux.png" class="attachment-full size-full wp-post-image" alt="Install MS SQL Server on Linux" loading="lazy" itemprop="image" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/install-microsoft-sql-server-in-linux/" rel="bookmark">How to Install SQL Server in RHEL, Rocky Linux and AlmaLinux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-43829 post type-post status-publish format-standard has-post-thumbnail hentry category-almalinux category-joomla category-rocky-linux wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/install-joomla-rocky-linux-and-almalinux/"  title="How to Install Joomla on Rocky Linux and AlmaLinux"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-Joomla-in-Rocky-Linux.png" width="720" height="340" class="attachment-full size-full wp-post-image" alt="Install Joomla in Rocky Linux" loading="lazy" itemprop="image"><noscript><img width="720" height="340" src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-Joomla-in-Rocky-Linux.png" class="attachment-full size-full wp-post-image" alt="Install Joomla in Rocky Linux" loading="lazy" itemprop="image" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/install-joomla-rocky-linux-and-almalinux/" rel="bookmark">How to Install Joomla on Rocky Linux and AlmaLinux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-43811 post type-post status-publish format-standard has-post-thumbnail hentry category-almalinux wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/install-lamp-in-almalinux/"  title="How to Install LAMP Stack in AlmaLinux 8.4"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-LAMP-in-AlmaLinux.png" width="720" height="340" class="attachment-full size-full wp-post-image" alt="Install LAMP in AlmaLinux" loading="lazy" itemprop="image"><noscript><img width="720" height="340" src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-LAMP-in-AlmaLinux.png" class="attachment-full size-full wp-post-image" alt="Install LAMP in AlmaLinux" loading="lazy" itemprop="image" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/install-lamp-in-almalinux/" rel="bookmark">How to Install LAMP Stack in AlmaLinux 8.4</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-43799 post type-post status-publish format-standard has-post-thumbnail hentry category-almalinux category-rocky-linux category-security wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/install-fail2ban-rocky-linux-almalinux/"  title="How to Install Fail2ban on Rocky Linux and AlmaLinux"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-Fail2ban-on-Rocky-Linux.png" width="720" height="340" class="attachment-full size-full wp-post-image" alt="Install Fail2ban on Rocky Linux and AlmaLinux" loading="lazy" itemprop="image"><noscript><img width="720" height="340" src="https://www.tecmint.com/wp-content/uploads/2021/09/Install-Fail2ban-on-Rocky-Linux.png" class="attachment-full size-full wp-post-image" alt="Install Fail2ban on Rocky Linux and AlmaLinux" loading="lazy" itemprop="image" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/install-fail2ban-rocky-linux-almalinux/" rel="bookmark">How to Install Fail2ban on Rocky Linux and AlmaLinux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><div class="wpsp-clear"></div></section><!-- .wp-show-posts --></div>	</div><!-- .inside-article -->
</article><!-- #post-## -->
<div class="comments-area">
<div id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Got something to say? Join the discussion. <small><a rel="nofollow" id="cancel-comment-reply-link" href="/install-cacti-on-rocky-linux-almalinux/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.tecmint.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p>
Have a question or suggestion? Please leave a comment to start the discussion. Please keep in mind that all comments are moderated and your email address will NOT be published.
</p><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" />
<label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30" />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class='comment-form-subscriptions'><label for='subscribe-reloaded'><input style='width:30px' type='checkbox' name='subscribe-reloaded' id='subscribe-reloaded' value='yes' /> Notify me of followup comments via e-mail. You can also <a href='https://www.tecmint.com/comment-subscriptions/?srp=43934&amp;srk=0b81c0e99cc43eb9ade2ba1b6ab240b4&amp;sra=s&amp;srsrc=f'>subscribe</a> without commenting.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='43934' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e7fa136df7" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="116"/><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->
</div>
</main><!-- #main -->
</div><!-- #primary -->
<div id="right-sidebar" class="widget-area grid-25 tablet-grid-25 grid-parent sidebar" itemtype="https://schema.org/WPSideBar" itemscope>
<div class="inside-right-sidebar">
<aside id="custom_html-10" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<div class="socialprofiles">
<p style="font-weight:800;color:#c33;font-size:20px;">Over 3,500,000+ Readers</p>
<a href="https://www.facebook.com/TecMint" target="_blank" rel="nofollow noopener noreferrer" title="Join TecMint on Facebook"><img alt="Join TecMint on Facebook" src="https://www.tecmint.com/wp-content/themes/tecmint/images/facebook.png"></a>
<a href="https://twitter.com/tecmint" target="_blank" rel="nofollow noopener noreferrer" title="Follow TecMint on Twitter"><img alt="Follow TecMint on Twitter" src="https://www.tecmint.com/wp-content/themes/tecmint/images/twitter.png"></a>
<a href="https://www.linkedin.com/company/tecmint" target="_blank" rel="nofollow noopener noreferrer" title="Join TecMint on LinkedIn"><img alt="Join TecMint on LinkedIn" src="https://www.tecmint.com/wp-content/themes/tecmint/images/linkedin.png"></a>
<a href="https://instagram.com/tecmint" target="_blank" rel="nofollow noopener noreferrer" title="Follow TecMint on Instagram"><img alt="Follow TecMint on Instagram" src="https://www.tecmint.com/wp-content/themes/tecmint/images/instagram.png"></a>
<a href="https://feedly.com/i/subscription/feed/https://www.tecmint.com/feed/" target="_blank" rel="nofollow noopener noreferrer" title="Follow TecMint via RSS Feed"><img alt="Follow TecMint via RSS Feed" src="https://www.tecmint.com/wp-content/themes/tecmint/images/rss.png"></a>
<a href="https://newsletter.tecmint.com/subscription?f=hj6Ohm9gck3Z0PQ2BBBTh892iaCbDV3jJJa3hD8ULUlubOgnbo8aF44vt2HZfdc36g" target="_blank" rel="nofollow noopener noreferrer" title="Subscribe to TecMint Newsletter"><img alt="Subscribe to TecMint Newsletter" src="https://www.tecmint.com/wp-content/themes/tecmint/images/newsletter.png"></a>
</div></center></div></aside><aside id="custom_html-9" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<!-- Tag ID: tecmint_right_rail_1 -->
<div align="center" id="tecmint_right_rail_1">
<script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_right_rail_1", slotId: "tecmint_right_rail_1" });
</script>
</div>
</center></div></aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a style="color: #c33;font-weight:700; text-align: center;    display: inline-block;text-decoration: underline;" href="https://www.tecmint.com/free-online-linux-learning-guide-for-beginners/" target="_blank" rel="noopener">A Beginners Guide To Learn Linux  for Free [with Examples]</a></div></aside><aside id="custom_html-4" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<!-- Tag ID: tecmint_right_rail_2 -->
<div align="center" id="tecmint_right_rail_2">
<script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_right_rail_2", slotId: "tecmint_right_rail_2" });
</script>
</div>
</center></div></aside><aside id="custom_html-5" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a style="color: #c33;font-weight:700; text-align: center;    display: inline-block;text-decoration: underline;" href="https://www.tecmint.com/red-hat-rhcsa-rhce-exam-certification-book/" target="_blank" rel="noopener">Red Hat RHCSA/RHCE 8 Certification Study Guide [eBooks]</a></div></aside><aside id="custom_html-6" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a style="color: #c33;font-weight:700; text-align: center;    display: inline-block;text-decoration: underline;" href="https://www.tecmint.com/linux-foundation-lfcs-lfce-certification-exam-book/" target="_blank" rel="noopener">Linux Foundation LFCS and LFCE Certification Study Guide [eBooks]</a></div></aside><aside id="custom_html-7" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<!-- Tag ID: tecmint_right_rail_3 -->
<div id="tecmint_right_rail_3" align="center"><script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_right_rail_3", slotId: "tecmint_right_rail_3" });
</script></div>
</center></div></aside><aside id="wpsp_widget-2" class="widget inner-padding widget_wpsp_widget"><h2 class="widget-title">Learn Linux Commands and Tools</h2><style>.wp-show-posts-columns#wpsp-38336 {margin-left: -2em; }.wp-show-posts-columns#wpsp-38336 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-38336" class=" wp-show-posts" style=""><article class=" wp-show-posts-single wpsp-clearfix post-23918 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-email-clients tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/send-email-attachment-from-linux-commandline/" rel="bookmark">4 Ways to Send Email Attachment from Linux Command Line</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-12571 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-sort-command" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/sort-command-linux/" rel="bookmark">14 Useful Examples of Linux &#8216;sort&#8217; Command &#8211; Part 1</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-28276 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-commandline-tools" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/whois-command-get-domain-and-ip-address-information/" rel="bookmark">How to Get Domain and IP Address Information Using WHOIS Command</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-29670 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-commandline-tools" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/fkill-kill-linux-process-by-name-or-pid/" rel="bookmark">fkill &#8211; Interactively Kill Processes in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-18215 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-ftp" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/restrict-sftp-user-home-directories-using-chroot/" rel="bookmark">How to Restrict SFTP Users to Home Directories Using chroot Jail</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-33506 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-nc-command-examples tag-netcat-command-examples" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/netcat-nc-command-examples/" rel="bookmark">8 Netcat (nc) Command with Examples</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article></section><!-- .wp-show-posts --></aside><aside id="custom_html-11" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<a rel="nofollow noopener" target="_blank" href="https://newsletter.tecmint.com/subscription?f=hj6Ohm9gck3Z0PQ2BBBTh892iaCbDV3jJJa3hD8ULUlubOgnbo8aF44vt2HZfdc36g"><img alt="Join TecMint Weekly Newsletter" src="https://www.tecmint.com/wp-content/uploads/2020/07/Tecmint-Email-Newsletter-Signup.png"/></a>
</center>
<p style="text-align:center;border-top: 2px dashed #8e8e8e;margin-top: 10px;padding-top: 10px;">If You Appreciate What We Do Here On TecMint, You Should Consider:</p>
<p align="center"><a href="https://www.buymeacoffee.com/tecmint" rel="nofollow noopener" target="_blank"><img alt="Support Us" src="https://www.tecmint.com/wp-content/uploads/2015/01/coffee.png"></a></p></div></aside>	</div><!-- .inside-right-sidebar -->
</div><!-- #secondary -->

</div><!-- #content -->
</div><!-- #page -->
<center style="padding-top:10px;padding-bottom:30px;">
<!-- Tag ID: tecmint_leaderboard_btf -->
<div id="tecmint_leaderboard_btf" align="center"><script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_leaderboard_btf", slotId: "tecmint_leaderboard_btf" });
</script></div>
</center>
<div class="site-footer footer-bar-active footer-bar-align-center">
<div id="footer-widgets" class="site footer-widgets">
<div class="footer-widgets-container grid-container grid-parent">
<div class="inside-footer-widgets">
<div class="footer-widget-1 grid-parent grid-33 tablet-grid-50 mobile-grid-100">
<aside id="wpsp_widget-3" class="widget inner-padding widget_wpsp_widget"><h2 class="widget-title">Linux Server Monitoring Tools</h2><style>.wp-show-posts-columns#wpsp-38337 {margin-left: -2em; }.wp-show-posts-columns#wpsp-38337 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-38337" class=" wp-show-posts" style=""><article class=" wp-show-posts-single wpsp-clearfix post-40479 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools category-ubuntu tag-netdata-monitoring-tool tag-ubuntu-server-monitoring tag-ubuntu-tips" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/monitor-ubuntu-performance-using-netdata/" rel="bookmark">How to Monitor Ubuntu Performance Using Netdata</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-30084 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands category-monitoring-tools tag-commandline-tools tag-linux-server-monitoring" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/whowatch-monitor-linux-users-and-processes-in-real-time/" rel="bookmark">whowatch &#8211; Monitor Linux Users and Processes in Real Time</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-29881 post type-post status-publish format-standard has-post-thumbnail hentry category-mariadb category-monitoring-tools category-mysql" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/monitor-mysql-mariadb-using-netdata-on-centos-7/" rel="bookmark">How to Monitor MySQL/MariaDB Databases using Netdata on CentOS 7</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-1193 post type-post status-publish format-standard has-post-thumbnail hentry category-centos category-fedora category-linux-distros category-monitoring-tools category-mysql category-redhat" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/install-mtop-mysql-database-server-monitoring-in-rhel-centos-6-5-4-fedora-17-12/" rel="bookmark">Install Mtop (MySQL Database Server Monitoring) in RHEL/CentOS 6/5/4, Fedora 17-12</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-26954 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools tag-linux-log-management tag-rsyslog" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/create-centralized-log-server-with-rsyslog-in-centos-7/" rel="bookmark">How to Create a Centralized Log Server with Rsyslog in CentOS/RHEL 7</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-27867 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools tag-nmap-commands" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/use-nmap-script-engine-nse-scripts-in-linux/" rel="bookmark">How to Use Nmap Script Engine (NSE) Scripts in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article></section><!-- .wp-show-posts --></aside>	</div>
<div class="footer-widget-2 grid-parent grid-33 tablet-grid-50 mobile-grid-100">
<aside id="wpsp_widget-4" class="widget inner-padding widget_wpsp_widget"><h2 class="widget-title">Learn Linux Tricks &#038; Tips</h2><style>.wp-show-posts-columns#wpsp-38338 {margin-left: -2em; }.wp-show-posts-columns#wpsp-38338 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-38338" class=" wp-show-posts" style=""><article class=" wp-show-posts-single wpsp-clearfix post-25131 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-commandline-tools tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/bd-quickly-go-back-to-a-linux-parent-directory/" rel="bookmark">bd &#8211; Quickly Go Back to a Parent Directory Instead of Typing &#8220;cd ../../..&#8221; Redundantly</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-18312 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/optimize-and-compress-jpeg-or-png-batch-images-linux-commandline/" rel="bookmark">How to Optimize and Compress JPEG or PNG Images in Linux Commandline</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-36122 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-commandline-tools tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/generate-pre-shared-key-in-linux/" rel="bookmark">4 Ways to Generate a Strong Pre-Shared Key (PSK) in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-15982 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/monitor-copy-backup-tar-progress-in-linux-using-pv-command/" rel="bookmark">How to Monitor Progress of (Copy/Backup/Compress) Data using &#8216;pv&#8217; Command</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-20051 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/set-path-variable-linux-permanently/" rel="bookmark">Learn How to Set Your $PATH Variables Permanently in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-23823 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/add-colors-to-command-output-terminal-linux/" rel="bookmark">Add Rainbow Colors to Linux Command Output in Slow Motion</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article></section><!-- .wp-show-posts --></aside>	</div>
<div class="footer-widget-3 grid-parent grid-33 tablet-grid-50 mobile-grid-100">
<aside id="wpsp_widget-5" class="widget inner-padding widget_wpsp_widget"><h2 class="widget-title">Best Linux Tools</h2><style>.wp-show-posts-columns#wpsp-38100 {margin-left: -2em; }.wp-show-posts-columns#wpsp-38100 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-38100" class=" wp-show-posts" style=""><article class=" wp-show-posts-single wpsp-clearfix post-17877 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools category-web-browsers tag-linux-web-browsers" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/linux-web-browsers/" rel="bookmark">16 Best Web Browsers I Discovered for Linux in 2020</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-28473 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools tag-cron-job-tools" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/online-cron-job-generator-and-tester-for-linux/" rel="bookmark">6 Online Tools for Generating and Testing Cron Jobs for Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-29661 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools tag-github-alternatives" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/github-alternatives-to-host-open-source-projects/" rel="bookmark">10 Best GitHub Alternatives to Host Open Source Projects</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-17714 post type-post status-publish format-standard has-post-thumbnail hentry category-editors category-top-tools tag-text-editors" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/linux-command-line-editors/" rel="bookmark">My Favorite Command Line Editors for Linux &#8211; What&#8217;s Your Editor?</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-33185 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools tag-linux-administration-tools" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/gui-tools-for-linux-system-administrators/" rel="bookmark">The 10 Top GUI Tools for Linux System Administrators</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-19665 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools tag-pdf-viewers" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/linux-pdf-viewers-and-readers-tools/" rel="bookmark">8 Best PDF Document Viewers for Linux Systems</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article></section><!-- .wp-show-posts --></aside>	</div>
</div>
</div>
</div>
<footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope>
<div class="inside-site-info grid-container grid-parent">
<div class="footer-bar">
<aside id="nav_menu-2" class="widget inner-padding widget_nav_menu"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-18572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18572"><a href="https://www.tecmint.com/donate-to-tecmint/">Donate to TecMint</a></li>
<li id="menu-item-10437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10437"><a href="https://www.tecmint.com/contact-us/">Contact Us</a></li>
<li id="menu-item-10442" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10442"><a href="https://www.tecmint.com/advertise/">Advertise on TecMint</a></li>
<li id="menu-item-10441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10441"><a href="https://www.tecmint.com/services/">Linux Services</a></li>
<li id="menu-item-10435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10435"><a href="https://www.tecmint.com/copyright-policy/">Copyright Policy</a></li>
<li id="menu-item-10436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10436"><a href="https://www.tecmint.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-13339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13339"><a href="https://www.tecmint.com/career/">Career</a></li>
<li id="menu-item-24288" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24288"><a href="https://www.tecmint.com/sponsored-post-guidelines-tecmint/">Sponsored Post</a></li>
</ul></div></aside>		</div>
<div class="copyright-bar">
Tecmint: Linux Howtos, Tutorials &amp; Guides &copy; 2021. All Rights Reserved.
<p>The material in this site cannot be republished either online or offline, without our permission.</p>
<p>Hosting Sponsored by : <a style="font-weight:bold;color:yellow" href="https://linode.gvw92c.net/tecmint" target="_blank" rel="nofollow">Linode Cloud Hosting</a></p>				</div>
</div>
</footer><!-- .site-info -->
</div><!-- .site-footer -->
<a title="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
<span class="screen-reader-text">Scroll back to top</span>
</a><div class="wplogout-float-social-wrapper hide-on-mobile hide-on-tablet">
<a class="wplogout-float-social-sharing wplogout-social-facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tecmint.com%2Finstall-cacti-on-rocky-linux-almalinux%2F" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"/></svg></a>
<a class="wplogout-float-social-sharing wplogout-social-twitter" href="https://twitter.com/intent/tweet?text=How+to+Install+Cacti+on+Rocky+Linux+and+AlmaLinux&amp;url=https%3A%2F%2Fwww.tecmint.com%2Finstall-cacti-on-rocky-linux-almalinux%2F&amp;via=tecmint" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"/></svg></a>
<a class="wplogout-float-social-sharing wplogout-social-linkedin" href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.tecmint.com%2Finstall-cacti-on-rocky-linux-almalinux%2F&amp;title=How+to+Install+Cacti+on+Rocky+Linux+and+AlmaLinux&amp;mini=true" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"/></svg></a>
<a class="wplogout-float-social-sharing wplogout-social-reddit" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.tecmint.com%2Finstall-cacti-on-rocky-linux-almalinux%2F&title=How+to+Install+Cacti+on+Rocky+Linux+and+AlmaLinux" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M24 11.779c0-1.459-1.192-2.645-2.657-2.645-.715 0-1.363.286-1.84.746-1.81-1.191-4.259-1.949-6.971-2.046l1.483-4.669 4.016.941-.006.058c0 1.193.975 2.163 2.174 2.163 1.198 0 2.172-.97 2.172-2.163s-.975-2.164-2.172-2.164c-.92 0-1.704.574-2.021 1.379l-4.329-1.015c-.189-.046-.381.063-.44.249l-1.654 5.207c-2.838.034-5.409.798-7.3 2.025-.474-.438-1.103-.712-1.799-.712-1.465 0-2.656 1.187-2.656 2.646 0 .97.533 1.811 1.317 2.271-.052.282-.086.567-.086.857 0 3.911 4.808 7.093 10.719 7.093s10.72-3.182 10.72-7.093c0-.274-.029-.544-.075-.81.832-.447 1.405-1.312 1.405-2.318zm-17.224 1.816c0-.868.71-1.575 1.582-1.575.872 0 1.581.707 1.581 1.575s-.709 1.574-1.581 1.574-1.582-.706-1.582-1.574zm9.061 4.669c-.797.793-2.048 1.179-3.824 1.179l-.013-.003-.013.003c-1.777 0-3.028-.386-3.824-1.179-.145-.144-.145-.379 0-.523.145-.145.381-.145.526 0 .65.647 1.729.961 3.298.961l.013.003.013-.003c1.569 0 2.648-.315 3.298-.962.145-.145.381-.144.526 0 .145.145.145.379 0 .524zm-.189-3.095c-.872 0-1.581-.706-1.581-1.574 0-.868.709-1.575 1.581-1.575s1.581.707 1.581 1.575-.709 1.574-1.581 1.574z"/></svg></a>
</div><!-- Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<script type="text/javascript" async=true>
(function() {
var host = window.location.hostname;
var element = document.createElement('script');
var firstScript = document.getElementsByTagName('script')[0];
var url = 'https://quantcast.mgr.consensu.org'
.concat('/choice/', 'XaecbbMz6DF2q', '/', host, '/choice.js')
var uspTries = 0;
var uspTriesLimit = 3;
element.async = true;
element.type = 'text/javascript';
element.src = url;
firstScript.parentNode.insertBefore(element, firstScript);
function makeStub() {
var TCF_LOCATOR_NAME = '__tcfapiLocator';
var queue = [];
var win = window;
var cmpFrame;
function addFrame() {
var doc = win.document;
var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);
if (!otherCMP) {
if (doc.body) {
var iframe = doc.createElement('iframe');
iframe.style.cssText = 'display:none';
iframe.name = TCF_LOCATOR_NAME;
doc.body.appendChild(iframe);
} else {
setTimeout(addFrame, 5);
}
}
return !otherCMP;
}
function tcfAPIHandler() {
var gdprApplies;
var args = arguments;
if (!args.length) {
return queue;
} else if (args[0] === 'setGdprApplies') {
if (
args.length > 3 &&
args[2] === 2 &&
typeof args[3] === 'boolean'
) {
gdprApplies = args[3];
if (typeof args[2] === 'function') {
args[2]('set', true);
}
}
} else if (args[0] === 'ping') {
var retr = {
gdprApplies: gdprApplies,
cmpLoaded: false,
cmpStatus: 'stub'
};
if (typeof args[2] === 'function') {
args[2](retr);
}
} else {
queue.push(args);
}
}
function postMessageEventHandler(event) {
var msgIsString = typeof event.data === 'string';
var json = {};
try {
if (msgIsString) {
json = JSON.parse(event.data);
} else {
json = event.data;
}
} catch (ignore) {}
var payload = json.__tcfapiCall;
if (payload) {
window.__tcfapi(
payload.command,
payload.version,
function(retValue, success) {
var returnMsg = {
__tcfapiReturn: {
returnValue: retValue,
success: success,
callId: payload.callId
}
};
if (msgIsString) {
returnMsg = JSON.stringify(returnMsg);
}
event.source.postMessage(returnMsg, '*');
},
payload.parameter
);
}
}
while (win) {
try {
if (win.frames[TCF_LOCATOR_NAME]) {
cmpFrame = win;
break;
}
} catch (ignore) {}
if (win === window.top) {
break;
}
win = win.parent;
}
if (!cmpFrame) {
addFrame();
win.__tcfapi = tcfAPIHandler;
win.addEventListener('message', postMessageEventHandler, false);
}
};
makeStub();
var uspStubFunction = function() {
var arg = arguments;
if (typeof window.__uspapi !== uspStubFunction) {
setTimeout(function() {
if (typeof window.__uspapi !== 'undefined') {
window.__uspapi.apply(window.__uspapi, arg);
}
}, 500);
}
};
var checkIfUspIsReady = function() {
uspTries++;
if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
console.warn('USP is not accessible');
} else {
clearInterval(uspInterval);
}
};
if (typeof window.__uspapi === 'undefined') {
window.__uspapi = uspStubFunction;
var uspInterval = setInterval(checkIfUspIsReady, 6000);
}
})();
</script>
<!-- End Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) --><script type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/light/js/jquery.fancybox.pack.js?ver=5.8.1' id='fancybox-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/light/js/light.js?ver=5.8.1' id='fancybox-load-js'></script>
<!--[if lte IE 11]>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/themes/tecmint/js/classList.min.js?ver=2.4.2' id='generate-classlist-js'></script>
<![endif]-->
<script type='text/javascript' src='https://www.tecmint.com/wp-content/themes/tecmint/js/menu.min.js?ver=2.4.2' id='generate-menu-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/themes/tecmint/js/a11y.min.js?ver=2.4.2' id='generate-a11y-js'></script>
<script type='text/javascript' id='generate-navigation-search-js-extra'>
/* <![CDATA[ */
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/themes/tecmint/js/navigation-search.min.js?ver=2.4.2' id='generate-navigation-search-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/themes/tecmint/js/back-to-top.min.js?ver=2.4.2' id='generate-back-to-top-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-includes/js/comment-reply.min.js?ver=5.8.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1' id='jquery-sonar-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1' id='wpcom-lazy-load-images-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/wp-show-posts/js/jquery.matchHeight.js?ver=1.1.3' id='wpsp-matchHeight-js'></script>
</body>
</html><!-- WP Fastest Cache file was created in 0.33550596237183 seconds, on 06-10-21 11:40:26 -->