PAC Manager: A Remote SSH/FTP/Telnet Session Management Tool

Linux Administrator must have been familiar with Telnet and SSH. These tools will help them to connect to the server remotely. But on their laptop / computer, they may not use a console based operating system. For those who use Linux on their laptop, there is another tool named PAC Manager.

Install PAC Manager in Linux
PAC Manager for Linux

What is PAC Manager?

PAC Manager is an open source GUI based tool for configuring and managing remote SSH/Telnet connections. It supports RDP, VNC, Macros, Cluster connections, pre/post connections, local executions, EXPECT regular expressions and much more. It can displays the connections in tabs or separate windows and it gives a notification icon for easy access to your configured connections.

Installation of PAC Manager in Linux

Since it’s basically a GUI interface, you may need to install SSH client and Telnet client on your computer. You may download the latest PAC Manager software at this URL:

  1. http://sourceforge.net/projects/pacmanager/files/pac-4.0/

PAC Manager is available in RPM, DEB and TAR.GZ packages. Both in 32 bit and 64 bit version. On Debian, Ubuntu and Linux Mint you may install it using dpkg command.

$ sudo wget -c http://downloads.sourceforge.net/project/pacmanager/pac-4.0/pac-4.5.3.2-all.deb 
$ sudo dpkg -i pac-4.5.3.2-all.deb

On RHEL, Fedora and CentOS you may install it using rpm command.

On 32 bit Systems
$ sudo wget -c http://downloads.sourceforge.net/project/pacmanager/pac-4.0/pac-4.5.3.2-2.i386.rpm 
$ sudo rpm -ivh pac-4.5.3.2-2.i386.rpm
On 64 bit Systems
$ sudo wget -c http://downloads.sourceforge.net/project/pacmanager/pac-4.0/pac-4.5.3.2-2.x86_64.rpm 
$ sudo rpm -ivh pac-4.5.3.2-2.x86_64.rpm

On my Linux Mint, I found error like this. If you also get similar error.

$ sudo dpkg -i pac-4.5.3.2-all.deb 

Selecting previously unselected package pac.
(Reading database ... 141465 files and directories currently installed.)
Unpacking pac (from pac-4.5.3.2-all.deb) ...
dpkg: dependency problems prevent configuration of pac:
.....

To fix it, you should run.

$ sudo apt-get -f install

The -f parameter tell apt-get to fix-broken dependencies. Then to make sure that the error has gone, I re-run the installation using dpkg command

Sample Output
[email protected] ~/Downloads $ sudo dpkg -i pac-4.5.3.2-all.deb 

(Reading database ... 142322 files and directories currently installed.)
Preparing to replace pac 4.5.3.2 (using pac-4.5.3.2-all.deb) ...
Unpacking replacement pac ...
Setting up pac (4.5.3.2) ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
[email protected] ~/Downloads $

PAC Manager Features

Here, we discuss some useful features with screenshots.

Multi Protocol

PAC supports multi protocol from FTP, SSH, RDP, VNC and many more. Please ensure the protocol that you need is already installed before create a connection with PAC Manager. For example on my Linux Mint, I have to install rdesktop package before creating a Remote Desktop (RDP) connection entry.

Multi Protocol
Multi Protocol

Once rdesktop installed, I can use RDP to remote Windows machine.

Install RDP
Install RDP
Tab Support

If you run multiple remote connections using PAC Manager, those connections will be shown in Tabs. PAC Manager can also display a local console in it’s Tab. Just click a terminal icon on the bottom. So you can manage remote connections and local console in the same Window.

Multi Tabs
Multi Tabs

You can also split connections display Just right click on the connections tab name, and choose Split > Horizontally with TAB or Vertically with TAB.

Connections Split Vertically
Connections Split Vertically
Proxy Support

When you are behind proxy server, PAC provide proxy parameter to be set. Proxy parameter can be set globally or for each connections.

Proxy Global
Proxy Global
Proxy Each Connections
Proxy Each Connections
Cluster Connections

If you manage multiple servers and you have the same task to do on those servers, you can use the Cluster connections feature. Cluster connection will open a window with multiple connections to specified hosts inside. Any text typed into one of the hosts will be replicated to all other connected and active hosts.

This feature will be useful if you need to run the same commands on each host. Performing these commands will ensure that all hosts are kept synced.

To add a cluster, you need to click on the Cluster tab which located on the left pane. Then click Manage Clusters to display PAC Cluster Management.

First, you have to create a Cluster name. Click Add button and give it a name. Next you can assign cluster members from Running Clusters, Saved Clusters or Auto Clusters on the right pane.

A list of available connections will appear in the left pane. You can choose them and click Add to cluster button. Then click OK to save it.

Cluster List
Cluster List
Cluster Management
Cluster Management

To run the cluster, you can back to Cluster tab. Choose the cluster name and click Connect button which available on the bottom.

Cluster Connections
Cluster Connections
KeePass Integration

Managing multiple servers mean managing multiple credentials. It is not easy to remember all credentials. For those who use KeePass Password Safe will happy to know this. PAC Manager can use KeePass database password to avoid user inputting credential manually.

PAC Manager can take credentials from KeePass database and load it automatically for you. Of course you have to supply KeePass master password to open the database.

To enable KeePass integration you must have KeePass software installed first. After that, you can select Infer ‘User / Password’ from KeePassX where parameter.

By default title field will be a reference to be checked by PAC Manager. The available fields are comment, created, password, title, url and username.

Keepass Integration
Keepass Integration

The next step is you need to provide a Perl Regulars Expression pattern to be checked inside the KeePass database. Then press Check button to see the result.

Keepass Authentication
Keepass Authentication

Of course there are many other interesting features in the PAC Manager such as Wake On LAN and scripting support via Perl script. This article simply peels the features that may be used in day-to-day needs.

Reference Links

PAC Manager Homepage

That’s it for now, I will be come-up again with another great article, till then stay tuned to TecMint.com for more such great howto’s. Please don’t forget to share and give your valuable comments.

If you liked this article, then do subscribe to email alerts for Linux tutorials. If you have any questions or doubts? do ask for help in the comments section.

If You Appreciate What We Do Here On TecMint, You Should Consider:

TecMint is the fastest growing and most trusted community site for any kind of Linux Articles, Guides and Books on the web. Millions of people visit TecMint! to search or browse the thousands of published articles available FREELY to all.

If you like what you are reading, please consider buying us a coffee ( or 2 ) as a token of appreciation.

Support Us

We are thankful for your never ending support.

23 thoughts on “PAC Manager: A Remote SSH/FTP/Telnet Session Management Tool”

  1. help me . i get the error code

    [email protected]:~/Downloads$ sudo dpkg -i pac-4.5.3.2-all.deb
    (Reading database … 164206 files and directories currently installed.)
    Preparing to unpack pac-4.5.3.2-all.deb …
    Unpacking pac (4.5.3.2) over (4.0.1) …
    dpkg: dependency problems prevent configuration of pac:
    pac depends on gtk2-engines-pixbuf; however:
    Package gtk2-engines-pixbuf is not installed.
    pac depends on libvte9; however:
    Package libvte9 is not installed.
    pac depends on libcairo-perl; however:
    Package libcairo-perl is not installed.
    pac depends on libgtk2-perl; however:
    Package libgtk2-perl is not installed.
    pac depends on libglib-perl; however:
    Package libglib-perl is not installed.
    pac depends on libpango-perl; however:
    Package libpango-perl is not installed.
    pac depends on libgnome2-gconf-perl; however:
    Package libgnome2-gconf-perl is not installed.
    pac depends on libexpect-perl; however:
    Package libexpect-perl is not installed.
    pac depends on libnet-proxy-perl; however:
    Package libnet-proxy-perl is not installed.
    pac depends on libyaml-perl; however:
    Package libyaml-perl is not installed.
    pac depends on libcrypt-cbc-perl; however:
    Package libcrypt-cbc-perl is not installed.
    pac depends on libcrypt-blowfish-perl; howev
    dpkg: error processing package pac (–install):
    dependency problems – leaving unconfigured
    Processing triggers for man-db (2.6.7.1-1) …
    Processing triggers for gnome-menus (3.10.1-0ubuntu2) …
    Processing triggers for desktop-file-utils (0.22-1ubuntu1) …
    Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) …
    Rebuilding /usr/share/applications/bamf-2.index…
    Processing triggers for mime-support (3.54ubuntu1) …
    Errors were encountered while processing:
    pac

    Reply
  2. On CentOS/REHL/OEL 6.5

    error: Failed dependencies:
    ftp is needed by pac-4.5.3.2-2.x86_64
    perl(Crypt::CBC) is needed by pac-4.5.3.2-2.x86_64
    perl(Crypt::Rijndael) is needed by pac-4.5.3.2-2.x86_64
    perl(Expect) is needed by pac-4.5.3.2-2.x86_64
    perl(Gnome2::GConf) is needed by pac-4.5.3.2-2.x86_64
    perl(Gtk2::Ex::Simple::List) is needed by pac-4.5.3.2-2.x86_64
    perl(Gtk2::Ex::Simple::TiedCommon) is needed by pac-4.5.3.2-2.x86_64
    perl(Gtk2::GladeXML) is needed by pac-4.5.3.2-2.x86_64
    perl(Net::ARP) is needed by pac-4.5.3.2-2.x86_64
    perl(OSSP::uuid) is needed by pac-4.5.3.2-2.x86_64
    perl(Socket6) is needed by pac-4.5.3.2-2.x86_64
    perl(YAML) is needed by pac-4.5.3.2-2.x86_64
    perl-Crypt-Blowfish is needed by pac-4.5.3.2-2.x86_64
    perl-Crypt-Rijndael is needed by pac-4.5.3.2-2.x86_64
    perl-IO-Stty is needed by pac-4.5.3.2-2.x86_64
    telnet is needed by pac-4.5.3.2-2.x86_64

    I am not familiar with perl modules that are not provided by default. How do I solve this “dependency”?

    Thanks

    Reply
    • Install those missing dependency packages using yum install package-name. For example, run the following command to install perl.

      # yum install perl
      
      Reply
      • Hi,

        I have encountered a similar issue, though I have perl installed already.

        I have installed manually the perl-Gtk2-Unique-0.05-2.el6.nux.x86_64.rpm, but still I’m getting the following errors:

        Error: Package: pac-4.5.4-2.x86_64 (/pac-4.5.4-2.x86_64)
        Requires: perl(Gnome2::GConf)
        Error: Package: pac-4.5.4-2.x86_64 (/pac-4.5.4-2.x86_64)
        Requires: perl(Gtk2::Ex::Simple::List)
        Error: Package: pac-4.5.4-2.x86_64 (/pac-4.5.4-2.x86_64)
        Requires: perl(Gtk2::GladeXML)
        Error: Package: pac-4.5.4-2.x86_64 (/pac-4.5.4-2.x86_64)
        Requires: perl(Gtk2::Ex::Simple::TiedCommon)

        Using a CentOS release 6.5 (Final).

        Any idea?

        Thanks

        Reply
        • These all packages are missing in your CentOS 6.5 distribution, please install them using following command.

          # yum install perl-Gnome2-GConf perl-Gtk2-Ex-Simple-List perl-Gtk2-GladeXML perl-Gtk2-Ex-Simple-List
          
          Reply
          • After all the aformentioned perl mods have been installed, it still tells me that it nees those dependencies. and even installing with –nodeps does not work.

            Can’t load ‘/usr/local/lib64/perl5/auto/OSSP/uuid/uuid.so’ for module OSSP::uuid: libuuid.so.16: cannot open shared object file: No such file or directory at /usr/local/lib64/perl5/XSLoader.pm line 68.
            at /usr/local/lib64/perl5/OSSP/uuid.pm line 331
            Compilation failed in require at /opt/pac/lib/PACMain.pm line 39.
            BEGIN failed–compilation aborted at /opt/pac/lib/PACMain.pm line 39.
            Compilation failed in require at /usr/bin/pac line 58.
            BEGIN failed–compilation aborted at /usr/bin/pac line 58.

            The library’s mentioned are in the correct locations.

            Any help would be great.

          • You can fix it by creating a new ld.so.conf file as shown below.

            # echo "/usr/local/lib" > /etc/ld.so.conf.d/uuid
            # ldconfig -f /etc/ld.so.conf.d/uuid
            

            # ldconfig -v | grep uuid

    • I’ve installed all dependencies on my machine (Fedora 21 Workstation) using these following steps:

      1 – Install all dependencies needed by PAC
      $ sudo yum install uuid-perl perl-Gnome2-GConf perl-Gtk2-Ex-Simple-List perl-Gtk2-GladeXML perl-Gtk2-Ex-Simple-List perl-Crypt-CBC perl-Crypt-Rijndael perl-Gtk2-Unique perl-Net-ARP perl-Socket6 perl-YAML perl-Crypt-Blowfish perl-IO-Stty

      2 – Download and install PAC
      $ sudo wget -c http://downloads.sourceforge.net/project/pacmanager/pac-4.0/pac-4.5.3.2-2.x86_64.rpm
      $ sudo rpm -ivh pac-4.5.3.2-2.x86_64.rpm

      Finally, I currently have these repositories list:
      $ yum repolist
      Loaded plugins: langpacks
      repo id repo name status
      fedora/21/x86_64 Fedora 21 – x86_64 42,816
      rpmforge RHEL 21 – RPMforge.net – dag 4,718
      rpmfusion-free/21/x86_64 RPM Fusion for Fedora 21 – Free 470
      rpmfusion-free-updates/21/x86_64 RPM Fusion for Fedora 21 – Free – Updates 206
      rpmfusion-nonfree/21/x86_64 RPM Fusion for Fedora 21 – Nonfree 178
      rpmfusion-nonfree-updates/21/x86_64 RPM Fusion for Fedora 21 – Nonfree – Updates 150
      updates/21/x86_64 Fedora 21 – x86_64 – Updates 9,106
      virtualbox/21/x86_64 Fedora 21 – x86_64 – VirtualBox 11
      repolist: 57,655

      Reply
  3. thanks for the post. I am trying to install on Mint 15. whether using dpkg or alien, I’m getting an error:

    error: pac-4.5.3.2-2.x86_64.rpm: not an rpm package (or package manifest):

    any thoughts ?

    Reply
    • Why you installing .rpm package on Linux Mint, it will won’t work. Linux Mint is based on .deb package management system, so you need to install .deb package as shown in the article.

      Reply
  4. How will this integrate with KDE? I’ll have to give this a try. Right now I’m using KRDC but it supports only VNC and RDP.

    Does anyone know a client which supports SSH, RDP and Teamviewer? KeePass integration is a nice bonus.

    Reply
    • I am sorry for late reply. I have never used solaris before. So I am not sure about what you mean. But in PAC software, I don’t find how to change background color.

      Reply
  5. I’ve been using PAC for a little while now. I think I first discovered it around the time that Ubuntu 12.04 came out. I use it to SSH into my Seed Box where I can run commands like MD5SUM on files so when I download them later (usually through uGet with the Aria2 plugin) I have a checksum value to ensure the the download went A-OK.

    Reply

Got something to say? Join the discussion.

Have a question or suggestion? Please leave a comment to start the discussion. Please keep in mind that all comments are moderated and your email address will NOT be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.