How to Upgrade Linux Mint 16 (Petra) to Linux Mint 17 (Qiana)

Download Your Free eBooks NOW - 10 Free Linux eBooks for Administrators

Matei Cezar

I'am a computer addicted guy, a fan of open source and linux based system software, have about 4 years experience with Linux distributions desktop, servers and bash scripting.

Receive Your Free Complimentary eBook NOW! -

Download Free Linux eBooks

Advanced Bash-Scripting Guide
Linux Bible
A Newbie's Getting Started Guide to Linux
Ubuntu Linux Toolbox: 1000+ Commands

You may also like...

86 Responses

  1. Lee says:

    I just want my old Petra-mint16 OS back. My HD was recently replaced and I’ve been unable to reboot the backup.img I made. I was able to restore all the old packages in /var/cache/apt/archive using apt-on-cd but now am getting errors that the old Petra – Ubuntu-Saucy libs no longer exisit. I tried changing Software-Sources to different mirros but nothing seems to work. I pointed my local repositry to “deb file:/var/cache/apt/archive and ran Apt-update then it forked. Is there and easy way to restore old packages with outhitting the lib-dependancy issue?

    • Matei Cezar says:

      Try to upgrade the system to e newer version of Linux Mint! Looks like the support period for Ubuntu Saucy has expired and the official repositories had been removed!

  2. Kimberly says:

    I’m getting this error:

    Preparing to unpack …/usb-modeswitch-data_20140327-1_all.deb …
    Unpacking usb-modeswitch-data (20140327-1) over (20120815-2) …
    Preparing to unpack …/wine-compholio_1.7.41~ubuntu14.04.1_i386.deb …
    Unpacking wine-compholio (1.7.41~ubuntu14.04.1) over (1.7.22~ubuntu13.10.1) …
    dpkg: error processing archive /var/cache/apt/archives/wine-compholio_1.7.41~ubuntu14.04.1_i386.deb (–unpack):
    trying to overwrite ‘/opt/wine-compholio/bin/wine’, which is also in package wine-compholio-i386 1.7.22~ubuntu13.10.1
    Preparing to unpack …/wine-compholio-i386_1.7.41~ubuntu14.04.1_i386.deb …
    Unpacking wine-compholio-i386 (1.7.41~ubuntu14.04.1) over (1.7.22~ubuntu13.10.1) …
    Processing triggers for ureadahead (0.100.0-16) …
    Processing triggers for doc-base (0.10.5) …
    Processing 9 changed doc-base files…
    Registering documents with scrollkeeper…
    Processing triggers for install-info (5.2.0.dfsg.1-2) …
    Processing triggers for ccache (3.1.9-1) …
    Updating symlinks in /usr/lib/ccache …
    Processing triggers for initramfs-tools (0.103ubuntu4.2) …
    update-initramfs: Generating /boot/initrd.img-3.11.0-12-generic
    Warning: No support for locale: en_US.utf8
    Errors were encountered while processing:
    /var/cache/apt/archives/wine-compholio_1.7.41~ubuntu14.04.1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    I’m new with Linux so I don’t know what to do. It’s gone so well up to this point.

    • Matei Cezar says:

      First try:
      sudo apt-get install -f
      sudo dpkg –configure -a

      If no success then run:
      sudo dpkg -i –force-overwrite /var/cache/apt/archives/wine-compholio_1.7.41~ubuntu14.04.1_i386.deb
      sudo apt-get autoremove
      sudo apt-get install -f

  3. Dave says:

    Very nicely done article. New to Linux, but have tried Zorin OS 9, and I like the feature that it automatically points the way to upgrade from older versions, by downloading sources, etc. I hope Linux Mint might consider this for the not so software inclined people such as myself. :-p Thank you!

  4. Rob says:

    Thank you. Worked perfectly. I hope that http://blog.linuxmint.com/?p=2725 (17 qiana to 17.1 rebecca) works as well.

  5. AMG says:

    sed: can’t read /ect/apt/sources.list.d/official-package-repositories.list: No such file or directory

    What went wrong?

  6. MIkem24 says:

    During upgrade – the last step…. When GRUB came up to chane or install, or to see differences, I chose “D”,
    but when I exited the editor that it started, I am unable to continue the upgrade,
    and if I run sudo apt-get upgrade -f again, it get the following:
    E: Could not get lock /var/lib/dpkg/lock – open (11: Resource temporarily unavailable)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

    How do I continue the process ?

    • Ravi Saive says:

      @Mlkem24,
      To fix such error, you need to delete the lock file with the below commands.

      $ sudo rm -rf /var/lib/apt/lists/lock
      # sudo rm -rf /var/cache/apt/archives/lock
      

      Restart the machine and try again…

  7. Steve says:

    I was using mint mate petra/saucy. I thought I would upgrade to trusty because it is lts. A lot of things (mate-settings-daemon, cairo-dock,nm-applet, etc) won’t start now with the following error:
    symbol lookup error: /usr/lib/x86_64-linux-gnu/libgdk-3.so.0: undefined symbol: cairo_surface_set_device_scale
    Any help out there would be appreciated! Thanks

  8. Abednego says:

    Processing triggers for hicolor-icon-theme (0.12-1ubuntu2) …

    (gtk-update-icon-cache:30354): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

    This likely means that your installation is broken.
    Try running the command:

      gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
    

    to make things work again for the time being.

    (gtk-update-icon-cache-3.0:30355): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file ‘/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

    This likely means that your installation is broken.
    Try running the command

      gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
    

    to make things work again for the time being.
    dpkg: libmatemenu: dependency problems, but removing anyway as you requested:
    mate-panel depends on libmatemenu; however:
    Package libmatemenu is to be removed.
    mate-menus depends on libmatemenu (= 1.6.0-1+petra).
    mate-control-center depends on libmatemenu; however:
    Package libmatemenu is to be removed.
    python-mate-menu depends on libmatemenu; however:
    Package libmatemenu is to be removed.

    Why? What’s wrong? :(

  9. Alvaro Garcia I. says:

    to block this line in the file sources.list, getdeb.list, official-package-repositories.list (###) with : ###deb cdrom:[Linux Mint 17 _Qiana_ – Release i386 20140530]/ trusty contrib main non-free

  10. Alvaro garcia Isordia says:

    for bloquear -file- with “deb” -sources.list, official-package-repositories.list-
    File “sources.list” :
    Only U Push It: ###

    ###deb cdrom:[Linux Mint 17 _Qiana_ – Release i386 20140530]/ trusty contrib main non-free

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Join Over 70000+ Linux Users
  1. 48590
  2. 2375
  3. 13200

Enter your email to get latest Linux Howto's