How to Enable EPEL Repository for RHEL/CentOS 7.x/6.x/5.x

If you have any questions or problems regarding this article and want help within 24 Hours? Ask Now

Support TecMint: Did you find this tutorial helpful?. Please help to keep it alive by donating. Every cent counts! - Donate Now

Ravi Saive

Simple Word a Computer Geek and Linux Guru who loves to share tricks and tips on Internet. Most Of My Servers runs on Open Source Platform called Linux.

Your name can also be listed here. Got a tip? Submit it here to become an TecMint author.

Receive Your Free Complimentary eBook NOW! -

Download Free Linux eBooks

Advanced Bash-Scripting Guide
Linux Bible
A Newbie's Getting Started Guide to Linux
Introduction to Linux - A Hands on Guide

You may also like...

115 Responses

  1. Marcos Nieto says:

    Other option:
    > yum install epel-release.noarch
    > yum update

  2. iqbal says:

    liblzma5-5.0.7-1.1.x86_64 has missing requires of libc.so.6(GLIBC_2.14)(64bit)
    rrdtool-1.5.4-3mgc30.x86_64 has missing requires of libc.so.6(GLIBC_2.14)(64bit)
    rrdtool-1.5.4-3mgc30.x86_64 has missing requires of libdbi.so.1()(64bit)
    rrdtool-1.5.4-3mgc30.x86_64 has missing requires of libffi.so.6()(64bit)
    rrdtool-1.5.4-3mgc30.x86_64 has missing requires of libpng16.so.16()(64bit)
    rrdtool-1.5.4-3mgc30.x86_64 has missing requires of libpng16.so.16(PNG16_0)(64bit)
    rrdtool-1.5.4-3mgc30.x86_64 has missing requires of librados.so.2()(64bit)
    rrdtool-1.5.4-3mgc30.x86_64 has missing requires of systemd
    rrdtool-1.5.4-3mgc30.x86_64 has missing requires of systemd
    rrdtool-1.5.4-3mgc30.x86_64 has missing requires of systemd
    systemd-units-217-11.1.mga5.x86_64 has installed conflicts initscripts (‘0’, ‘1.3.61’, ‘2’)
    systemd-units-217-11.1.mga5.x86_64 has missing requires of libc.so.6(GLIBC_2.14)(64bit)
    systemd-units-217-11.1.mga5.x86_64 has missing requires of libc.so.6(GLIBC_2.16)(64bit)
    systemd-units-217-11.1.mga5.x86_64 has missing requires of libc.so.6(GLIBC_2.17)(64bit)
    systemd-units-217-11.1.mga5.x86_64 has missing requires of liblzma.so.5(XZ_5.0)(64bit)
    systemd-units-217-11.1.mga5.x86_64 has missing requires of systemd = (‘0’, ‘217’, ‘11.1.mga5’)

    • Ravi Saive says:

      @Iqbal,

      On which distribution you’ve enabled EPEL and what version of EPEL? It seems you’ve installed wrong version of EPEL on wrong version of distribution.

  3. Reality Check says:

    This post is the top result in google search. Please, please, fix your instructions, which are far more complicated than necessary.

    The epel-release package is available in the default CentOS install. So there is no need to wget and install the package manually. There is no need for users to figure out if they have 32 or 64 bit version. The entire instruction, for Centos 6 and 7, is to run (as root):

    yum install epel-release

    That’s it.

  1. November 18, 2015

    […] RHEL/CentOS based distributions, you must have EPEL repository installed and enabled on the system to install fabric […]

  2. December 1, 2015

    […] sync the well-known EPEL repository to a subdirectory called epel-local inside the current working […]

  3. January 14, 2016

    […] For more information on how to install and enable additional package repository for this setup, see Epel’s installation […]

  4. January 19, 2016

    […] RPM based systems like RHEL, CentOS, Fedora etc., you need to install and enable EPEL repository or alternatively, you can install the epel repository directly from the commandline as […]

  5. January 27, 2016

    […] install Docker, the Epel repositories must be enabled on your system by issuing the following […]

Leave a Reply

Your email address will not be published. Required fields are marked *

Join Over 95000+ Linux Users
  1. 66,682
  2. 3,836
  3. 31,647

Enter your email to get latest Linux Howto's