<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<link rel="profile" href="https://gmpg.org/xfn/11">
<title>tuptime - Shows Historical and Statistical Running Time of Linux Systems</title>
<!-- All in One SEO 4.1.3.3 -->
<meta name="description" content="tuptime is a tool used for reporting the historical and statistical running time (uptime) of a Linux system, which keeps it between restarts, similar to uptime."/>
<meta name="google-site-verification" content="Lm2_CHFkgECZgEzZiN-gzDJYEF-xw7OMoGrpvemM-rs" />
<meta name="msvalidate.01" content="A92F4825ED7ABD97DAACAC1C05B9AF8E" />
<meta name="yandex-verification" content="327bf54006030f4a" />
<meta name="keywords" content="check uptime of linux,find linux uptime,how long linux server is running,linux check shutdown time,find linux reboot time,commandline tools" />
<link rel="canonical" href="https://www.tecmint.com/find-linux-uptime-shutdown-and-reboot-time-with-tuptime/" />
<!-- All in One SEO -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Tecmint: Linux Howtos, Tutorials &amp; Guides &raquo; Feed" href="https://www.tecmint.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Tecmint: Linux Howtos, Tutorials &amp; Guides &raquo; Comments Feed" href="https://www.tecmint.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Tecmint: Linux Howtos, Tutorials &amp; Guides &raquo; tuptime &#8211; Shows Historical and Statistical Running Time of Linux Systems Comments Feed" href="https://www.tecmint.com/find-linux-uptime-shutdown-and-reboot-time-with-tuptime/feed/" />
<link crossorigin="anonymous" rel='stylesheet' id='generate-fonts-css'  href='//fonts.googleapis.com/css?family=Muli:200,200italic,300,300italic,regular,italic,600,600italic,700,700italic,800,800italic,900,900italic|Nunito:200,200italic,300,300italic,regular,italic,600,600italic,700,700italic,800,800italic,900,900italic' type='text/css' media='all' />
<!-- <link rel='stylesheet' id='fancybox-style-css'  href='https://www.tecmint.com/wp-content/plugins/light/css/jquery.fancybox.css?ver=5.8' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='wp-show-posts-css'  href='https://www.tecmint.com/wp-content/plugins/wp-show-posts/css/wp-show-posts-min.css?ver=1.1.3' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='generate-style-css'  href='https://www.tecmint.com/wp-content/themes/tecmint/css/all.min.css?ver=2.4.2' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.tecmint.com/wp-content/cache/wpfc-minified/e75es2me/2lood.css" media="all"/>
<style id='generate-style-inline-css' type='text/css'>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</style>
<!-- <link rel='stylesheet' id='generate-child-css'  href='https://www.tecmint.com/wp-content/themes/tecmint_child/style.css?ver=1595914191' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='generate-secondary-nav-css'  href='https://www.tecmint.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style.min.css?ver=2.0.3' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.tecmint.com/wp-content/cache/wpfc-minified/qnfcpyr/2lood.css" media="all"/>
<style id='generate-secondary-nav-inline-css' type='text/css'>
.secondary-navigation{background-color:#0a1e48;}.secondary-navigation .top-bar{color:#ffffff;line-height:60px;font-family:"Nunito", sans-serif;font-weight:900;text-transform:none;font-size:15px;}.secondary-navigation .top-bar a{color:#ffffff;}.secondary-navigation .top-bar a:hover, .secondary-navigation .top-bar a:focus{color:#303030;}.secondary-navigation .main-nav ul li a,.secondary-navigation .menu-toggle,.secondary-menu-bar-items .menu-bar-item > a{color:#ffffff;font-family:"Nunito", sans-serif;font-weight:900;font-size:15px;line-height:60px;}.secondary-navigation .secondary-menu-bar-items{color:#ffffff;font-size:15px;}button.secondary-menu-toggle:hover,button.secondary-menu-toggle:focus{color:#ffffff;}.widget-area .secondary-navigation{margin-bottom:20px;}.secondary-navigation ul ul{background-color:#303030;top:auto;}.secondary-navigation .main-nav ul ul li a{color:#ffffff;font-size:14px;}.secondary-navigation .main-nav ul li:hover > a,.secondary-navigation .main-nav ul li:focus > a,.secondary-navigation .main-nav ul li.sfHover > a,.secondary-menu-bar-items .menu-bar-item:hover > a{color:#ff6060;background-color:#303030;}.secondary-navigation .main-nav ul ul li:hover > a,.secondary-navigation .main-nav ul ul li:focus > a,.secondary-navigation .main-nav ul ul li.sfHover > a{color:#ffffff;background-color:#474747;}.secondary-navigation .main-nav ul li[class*="current-menu-"] > a, .secondary-navigation .main-nav ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul li[class*="current-menu-"].sfHover > a{color:#f1c40f;background-color:#031230;}.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a,.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul ul li[class*="current-menu-"].sfHover > a{color:#ffffff;background-color:#474747;}@media (max-width:768px) {.secondary-menu-bar-items .menu-bar-item:hover > a{background: none;color: #ffffff;}}
</style>
<!-- <link rel='stylesheet' id='generate-secondary-nav-mobile-css'  href='https://www.tecmint.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style-mobile.min.css?ver=2.0.3' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.tecmint.com/wp-content/cache/wpfc-minified/g4dzjuqj/2lood.css" media="all"/>
<script src='//www.tecmint.com/wp-content/cache/wpfc-minified/fhgf5ep8/2lood.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://www.tecmint.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> -->
<!-- <script type='text/javascript' src='https://www.tecmint.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> -->
<link rel="https://api.w.org/" href="https://www.tecmint.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.tecmint.com/wp-json/wp/v2/posts/16181" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.tecmint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.tecmint.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.tecmint.com/?p=16181' />
<link rel="alternate" type="application/json+oembed" href="https://www.tecmint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tecmint.com%2Ffind-linux-uptime-shutdown-and-reboot-time-with-tuptime%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.tecmint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tecmint.com%2Ffind-linux-uptime-shutdown-and-reboot-time-with-tuptime%2F&#038;format=xml" />
<!-- Facebook Like Thumbnail (v0.4) -->
<meta property="og:image" content="https://www.tecmint.com/wp-content/uploads/2015/10/Find-Linux-Uptime.png" />
<!-- using featured thumbnail -->
<!-- Facebook Like Thumbnail (By Ashfame - https://github.com/ashfame/facebook-like-thumbnail) -->
<meta name="viewport" content="width=device-width, initial-scale=1"><!-- Google Sitelinks Search Box -->    
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "WebSite",
"url": "https://www.tecmint.com/",
"potentialAction": {
"@type": "SearchAction",
"target": "https://www.tecmint.com/?q={search_term}",
"query-input": "required name=search_term"
}
}
</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-33207530-1"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-33207530-1');
</script>
<!-- PLACE THIS SECTION INSIDE OF YOUR HEAD TAGS -->
<script data-cfasync="false" type="text/javascript">
var freestar = freestar || {};
freestar.hitTime = Date.now();
freestar.queue = freestar.queue || [];
freestar.config = freestar.config || {};
freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;
freestar.config.enabled_slots = [];
!function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/tecmint-com";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
freestar.initCallback = function () { (freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false : freestar.newAdSlots(freestar.config.enabled_slots) }
</script>
<!-- PLACE THIS SECTION INSIDE OF YOUR BODY TAGS -->
<link rel="amphtml" href="https://www.tecmint.com/find-linux-uptime-shutdown-and-reboot-time-with-tuptime/amp/"><link rel="icon" href="https://www.tecmint.com/wp-content/uploads/2020/07/favicon.ico" sizes="32x32" />
<link rel="icon" href="https://www.tecmint.com/wp-content/uploads/2020/07/favicon.ico" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.tecmint.com/wp-content/uploads/2020/07/favicon.ico" />
<meta name="msapplication-TileImage" content="https://www.tecmint.com/wp-content/uploads/2020/07/favicon.ico" />
<style type="text/css" id="wp-custom-css">
.alertbox {background-color: #edf7fe;border-left: 4px solid #bde2fb;display: block;padding: 10px;margin-bottom: 25px;}
.alertbox a {color:#bb0e30;text-decoration:underline;}
.entry-content p a:visited {
color: #c33;
}
</style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-16181 single-format-standard wp-custom-logo wp-embed-responsive post-image-above-header post-image-aligned-center secondary-nav-above-header secondary-nav-aligned-center right-sidebar nav-below-header fluid-header separate-containers active-footer-widgets-3 nav-search-enabled nav-aligned-center header-aligned-left dropdown-hover featured-image-active" itemtype="https://schema.org/Blog" itemscope>
<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>		<div class="top-bar top-bar-align-center">
<div class="inside-top-bar grid-container grid-parent">
<aside id="custom_html-3" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script language="JavaScript">
<!--
var r_text = new Array ();
r_text[0] = "<a target='_blank' rel='noopener noreferrer' href='https://www.tecmint.com/red-hat-rhcsa-rhce-exam-certification-book/'>RedHat RHCSA and RHCE Certification Preparation Guide</a> - <a class='button' href='https://www.tecmint.com/red-hat-rhcsa-rhce-exam-certification-book/' target='_blank' rel='noopener noreferrer'>Get This Book</a>";
r_text[1] = "<a target='_blank' rel='noopener noreferrer' href='https://www.tecmint.com/linux-foundation-lfcs-lfce-certification-exam-book/'>Linux Foundation LFCS and LFCE Certification Preparation Guide</a> - <a class='button orange' href='https://www.tecmint.com/linux-foundation-lfcs-lfce-certification-exam-book/' target='_blank' rel='noopener noreferrer'>Get This Book</a>";
r_text[2] = "<a target='_blank' rel='noopener noreferrer' href='https://www.tecmint.com/learn-linux-in-one-week/'>Learn Linux in One Week and Go From Zero to Hero</a> - <a class='button midnight-blue' href='https://www.tecmint.com/learn-linux-in-one-week/' target='_blank' rel='noopener noreferrer'>Get This Book</a>";
var i = Math.floor(3*Math.random())
document.write(r_text[i]);
//-->
</script></div></aside>			</div>
</div>
<nav id="secondary-navigation" class="secondary-navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope">
<div class="inside-navigation">
<button class="menu-toggle secondary-menu-toggle">
<span class="mobile-menu">Menu</span>					</button>
<div class="main-nav"><ul id="menu-home" class=" secondary-menu sf-menu"><li id="menu-item-334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-334"><a href="https://www.tecmint.com">Home</a></li>
<li id="menu-item-10774" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10774"><a target="_blank" rel="noopener" href="https://www.tecmint.com/who-we-are/">About</a></li>
<li id="menu-item-3912" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3912"><a title="Linux eBooks" target="_blank" rel="noopener" href="https://www.tecmint.com/linux-books-in-pdf-format/">eBooks</a></li>
<li id="menu-item-17151" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17151"><a title="Linux and Programming Online Courses" target="_blank" rel="noopener" href="https://deals.tecmint.com">Shop</a></li>
<li id="menu-item-18575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18575"><a title="Support Us" href="https://www.tecmint.com/donate-to-tecmint/">Donate</a></li>
<li id="menu-item-11736" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11736"><a target="_blank" rel="noopener" href="https://www.tecmint.com/linux-online-training-courses/">Linux Online Courses</a></li>
<li id="menu-item-11907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11907"><a title="Subscribe to TecMint Linux Updates" target="_blank" rel="noopener" href="https://www.tecmint.com/subscribe-to-blog/">Subscribe to Newsletter</a></li>
<li id="menu-item-13338" class="hosting menu-item menu-item-type-custom menu-item-object-custom menu-item-13338"><a title="Best Web Hosting Companies" target="_blank" rel="noopener" href="https://www.tecmint.com/best-web-hosting-for-linux/">Linux Hosting</a></li>
<li id="menu-item-24734" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24734"><a title="Linux Commands &#8211; A Beginners Cheat Sheet" target="_blank" rel="noopener" href="https://www.tecmint.com/linux-commands-cheat-sheet/">A-Z Linux Commands</a></li>
<li id="menu-item-38581" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-38581"><a target="_blank" rel="noopener">Get Involved<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-38583" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38583"><a target="_blank" rel="noopener" href="https://www.tecmint.com/testimonials/">Testimonials</a></li>
<li id="menu-item-38592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38592"><a target="_blank" rel="noopener" href="https://www.tecmint.com/submit-articles/">Join TecMint</a></li>
<li id="menu-item-38582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38582"><a target="_blank" rel="noopener" href="https://www.tecmint.com/submit-article-request/">Submit Article Request</a></li>
<li id="menu-item-38589" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38589"><a target="_blank" rel="noopener" href="https://www.tecmint.com/suggest-an-update/">Suggest an Update</a></li>
</ul>
</li>
</ul></div>				</div><!-- .inside-navigation -->
</nav><!-- #secondary-navigation -->
<header id="masthead" class="site-header" itemtype="https://schema.org/WPHeader" itemscope>
<div class="inside-header grid-container grid-parent">
<div class="header-widget">
<aside id="custom_html-2" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><!-- Tag ID: tecmint_leaderboard_atf -->
<div align="center" id="tecmint_leaderboard_atf">
<script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_leaderboard_atf", slotId: "tecmint_leaderboard_atf" });
</script>
</div></div></aside>			</div>
<div class="site-logo">
<a href="https://www.tecmint.com/" title="Tecmint: Linux Howtos, Tutorials &amp; Guides" rel="home">
<img  class="header-image" alt="Tecmint: Linux Howtos, Tutorials &amp; Guides" src="https://www.tecmint.com/wp-content/uploads/2020/07/logo.png" title="Tecmint: Linux Howtos, Tutorials &amp; Guides" />
</a>
</div>			</div><!-- .inside-header -->
</header><!-- #masthead -->
<nav id="site-navigation" class="main-navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope>
<div class="inside-navigation">
<form method="get" class="search-form navigation-search" action="https://www.tecmint.com/">
<input type="search" class="search-field" value="" name="s" title="Search" />
</form>		<div class="mobile-bar-items">
<span class="search-item">
<a aria-label="Open Search Bar" href="#">
</a>
</span>
</div><!-- .mobile-bar-items -->
<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="mobile-menu">Menu</span>				</button>
<div id="primary-menu" class="main-nav"><ul id="menu-header" class=" menu sf-menu"><li id="menu-item-10770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10770"><a href="https://www.tecmint.com/best-linux-distributions/">Linux Distro&#8217;s<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-42825" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42825"><a href="https://www.tecmint.com/centos-alternative-distributions/">CentOS Alternatives</a></li>
<li id="menu-item-40008" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40008"><a href="https://www.tecmint.com/linux-distro-for-power-users/">Best Linux Distros</a></li>
<li id="menu-item-40934" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40934"><a href="https://www.tecmint.com/redhat-based-linux-distributions/">RedHat Distributions</a></li>
<li id="menu-item-39889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39889"><a href="https://www.tecmint.com/best-linux-distributions-for-beginners/">Linux Distros for Beginners</a></li>
<li id="menu-item-39890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39890"><a href="https://www.tecmint.com/10-best-linux-server-distributions/">Linux Server Distros</a></li>
<li id="menu-item-39884" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39884"><a href="https://www.tecmint.com/debian-based-linux-distributions/">Debian Distributions</a></li>
<li id="menu-item-39885" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39885"><a href="https://www.tecmint.com/ubuntu-based-linux-distributions/">Ubuntu Distributions</a></li>
<li id="menu-item-39893" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39893"><a href="https://www.tecmint.com/arch-based-linux-distributions/">Arch Linux Distros</a></li>
<li id="menu-item-39886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39886"><a href="https://www.tecmint.com/best-rolling-release-linux-distributions/">Rolling Linux Distros</a></li>
<li id="menu-item-39887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39887"><a href="https://www.tecmint.com/best-linux-distributions-for-kde-plasma/">KDE Linux Distros</a></li>
<li id="menu-item-39892" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39892"><a href="https://www.tecmint.com/best-security-centric-linux-distributions/">Secure Linux Distros</a></li>
<li id="menu-item-39888" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39888"><a href="https://www.tecmint.com/linux-distributions-for-old-computers/">Linux Distros for Old PC</a></li>
<li id="menu-item-39891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39891"><a href="https://www.tecmint.com/new-linux-distributions/">New Linux Distros</a></li>
<li id="menu-item-39894" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39894"><a href="https://www.tecmint.com/best-linux-distributions-for-kids/">Linux Distros for Kids</a></li>
<li id="menu-item-39895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39895"><a href="https://www.tecmint.com/best-alternative-linux-distributions-for-windows-users/">Linux Distros for Windows Users</a></li>
</ul>
</li>
<li id="menu-item-10771" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10771"><a title="Linux Interview Questions" target="_blank" rel="noopener" href="https://www.tecmint.com/category/interview-questions/">FAQ&#8217;s</a></li>
<li id="menu-item-20869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-20869"><a href="https://www.tecmint.com/#">Programming<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-10772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10772"><a title="Learn Linux Shell Scripting" href="https://www.tecmint.com/category/bash-shell/">Shell Scripting</a></li>
<li id="menu-item-20870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20870"><a href="https://www.tecmint.com/category/python/">Learn Python</a></li>
<li id="menu-item-20871" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20871"><a href="https://www.tecmint.com/category/awk-command/">Learn Awk</a></li>
</ul>
</li>
<li id="menu-item-10773" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10773"><a href="https://www.tecmint.com/category/linux-commands/">Linux Commands</a></li>
<li id="menu-item-14795" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14795"><a href="https://www.tecmint.com/tag/linux-tricks/">Linux Tricks</a></li>
<li id="menu-item-19684" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19684"><a href="https://www.tecmint.com/category/top-tools/">Best Linux Tools</a></li>
<li id="menu-item-10443" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-10443"><a target="_blank" rel="noopener" href="https://www.tecmint.com/#">Certifications<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-14880" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14880"><a href="https://www.tecmint.com/how-to-setup-and-configure-static-network-routing-in-rhel/">RHCE Exam</a></li>
<li id="menu-item-11906" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11906"><a target="_blank" rel="noopener" href="https://www.tecmint.com/rhcsa-exam-reviewing-essential-commands-system-documentation/">RHCSA Exam</a></li>
<li id="menu-item-10444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10444"><a target="_blank" rel="noopener" href="https://www.tecmint.com/installing-network-services-and-configuring-services-at-system-boot/">LFCE Exam</a></li>
<li id="menu-item-14793" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14793"><a href="https://www.tecmint.com/sed-command-to-create-edit-and-manipulate-files-in-linux/">LFCS Exam</a></li>
<li id="menu-item-42469" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42469"><a title="LFCA Certification Guide" target="_blank" rel="noopener" href="https://www.tecmint.com/understanding-linux-operating-system/">LFCA Exam</a></li>
<li id="menu-item-34401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34401"><a title="Red Hat Ansible Exam Preparation Guide" target="_blank" rel="noopener" href="https://www.tecmint.com/understand-core-components-of-ansible/">Ansible Exam</a></li>
</ul>
</li>
<li id="menu-item-12399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-12399"><a href="https://www.tecmint.com/#">Guides<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-40716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40716"><a href="https://www.tecmint.com/best-practices-for-deploying-hadoop-server-on-centos/">Hadoop Series</a></li>
<li id="menu-item-18564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18564"><a target="_blank" rel="noopener" href="https://www.tecmint.com/install-docker-and-learn-containers-in-centos-rhel-7-6/">Docker Series</a></li>
<li id="menu-item-17150" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17150"><a href="https://www.tecmint.com/setup-postfix-mail-server-and-dovecot-with-mariadb-in-centos/">Postfix Mail</a></li>
<li id="menu-item-15041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15041"><a href="https://www.tecmint.com/citrix-xenserver-installation-and-network-configuration-in-linux/">XenServer Series</a></li>
<li id="menu-item-14794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14794"><a href="https://www.tecmint.com/install-redhat-virtualization-rhev/">RHEV Series</a></li>
<li id="menu-item-14805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14805"><a href="https://www.tecmint.com/what-is-clustering-and-advantages-disadvantages-of-clustering-in-linux/">Clustering Series</a></li>
<li id="menu-item-12400" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12400"><a href="https://www.tecmint.com/create-lvm-storage-in-linux/">LVM Series</a></li>
<li id="menu-item-12402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12402"><a href="https://www.tecmint.com/understanding-raid-setup-in-linux/">RAID Series</a></li>
<li id="menu-item-12403" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12403"><a href="https://www.tecmint.com/install-and-configure-kvm-in-linux/">KVM Series</a></li>
<li id="menu-item-12401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12401"><a href="https://www.tecmint.com/create-centralized-secure-storage-using-iscsi-targetin-linux/">iSCSI Series</a></li>
<li id="menu-item-12406" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12406"><a href="https://www.tecmint.com/install-zentyal-as-primary-domain-controller-and-integrate-windows-system/">Zentyal Series</a></li>
<li id="menu-item-16084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16084"><a href="https://www.tecmint.com/install-and-configure-ansible-automation-tool-in-linux/">Ansible Series</a></li>
<li id="menu-item-16395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16395"><a href="https://www.tecmint.com/install-and-configure-django-web-framework-in-centos-debian-ubuntu/">Django Series</a></li>
<li id="menu-item-14603" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14603"><a href="https://www.tecmint.com/create-gui-applications-in-linux/">Create GUI Apps</a></li>
</ul>
</li>
<li id="menu-item-14796" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-14796"><a href="https://www.tecmint.com/command-line-tools-to-monitor-linux-performance/">Monitoring Tools<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
<li id="menu-item-14797" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14797"><a href="https://www.tecmint.com/install-nagios-in-linux/">Nagios</a></li>
<li id="menu-item-14798" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14798"><a href="https://www.tecmint.com/install-and-configure-zabbix-monitoring-on-debian-centos-rhel/">Zabbix</a></li>
<li id="menu-item-14799" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14799"><a href="https://www.tecmint.com/install-cacti-network-monitoring-on-rhel-centos-6-3-5-8-and-fedora-17-12/">Cacti</a></li>
<li id="menu-item-14800" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14800"><a href="https://www.tecmint.com/install-observium-in-centos/">Observium</a></li>
<li id="menu-item-14801" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14801"><a href="https://www.tecmint.com/monitorix-a-lightweight-system-and-network-monitoring-tool-for-linux/">Monitorix</a></li>
<li id="menu-item-14802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14802"><a href="https://www.tecmint.com/install-collectd-and-collectd-web-to-monitor-server-resources-in-linux/">Collectd</a></li>
<li id="menu-item-14803" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14803"><a href="https://www.tecmint.com/linux-performance-monitoring-with-collectl-tool/">Collectl</a></li>
<li id="menu-item-14804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14804"><a href="https://www.tecmint.com/mysql-performance-monitoring/">MySQL Monitoring</a></li>
</ul>
</li>
<li class="search-item"><a aria-label="Open Search Bar" href="#"></a></li></ul></div>			</div><!-- .inside-navigation -->
</nav><!-- #site-navigation -->
<div id="page" class="hfeed site grid-container container grid-parent">
<div id="content" class="site-content">
<div id="primary" class="content-area grid-parent mobile-grid-100 grid-75 tablet-grid-75">
<main id="main" class="site-main">
<article id="post-16181" class="post-16181 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-commandline-tools" itemtype="https://schema.org/CreativeWork" itemscope>
<div class="inside-article">
<header class="entry-header">
<h1 class="entry-title" itemprop="headline">tuptime &#8211; Shows Historical and Statistical Running Time of Linux Systems</h1>			<div class="entry-meta">
<span class="byline"><span class="author vcard" itemtype="http://schema.org/Person" itemscope="itemscope" itemprop="author"><a href="https://www.tecmint.com/author/aaronkili/" title="View all posts by Aaron Kili" rel="author"><span class="author-name" itemprop="name">Aaron Kili</span></a></span></span><span class="posted-on"><time class="updated" datetime="2015-10-18T14:27:40+05:30" itemprop="dateModified">October 18, 2015</time><time class="entry-date published" datetime="2015-10-16T16:55:44+05:30" itemprop="datePublished">October 16, 2015</time> </span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.tecmint.com/category/linux-commands/" rel="category tag">Linux Commands</a></span> <span class="comments-link"><a href="https://www.tecmint.com/find-linux-uptime-shutdown-and-reboot-time-with-tuptime/#respond">Leave a comment</a></span> 			</div><!-- .entry-meta -->
<center style="padding-bottom:20px;padding-top:40px;">
<!-- Tag ID: tecmint_leaderboard_article_top -->
<div align="center" id="tecmint_leaderboard_article_top">
<script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_leaderboard_article_top", slotId: "tecmint_leaderboard_article_top" });
</script>
</div>
</center>
</header><!-- .entry-header -->
<div class="entry-content" itemprop="text">
<p>System Administration involves many activities one of which is monitoring and checking for how long your Linux system has been running. It is always a good idea to keep track of system <strong>uptime</strong> in order to optimize the use of system resources.  </p>
<figure id="attachment_16224" aria-describedby="caption-attachment-16224" style="width: 610px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2015/10/Find-Linux-Uptime.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2015/10/Find-Linux-Uptime.png" loading="lazy" alt="Find Linux Uptime, Shutdown and Reboot Time" width="620" height="296" class="size-medium wp-image-16224" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/Find-Linux-Uptime.png 718w, https://www.tecmint.com/wp-content/uploads/2015/10/Find-Linux-Uptime-620x296.png 620w" sizes="(max-width: 620px) 100vw, 620px"><noscript><img loading="lazy" src="https://www.tecmint.com/wp-content/uploads/2015/10/Find-Linux-Uptime.png" alt="Find Linux Uptime, Shutdown and Reboot Time" width="620" height="296" class="size-medium wp-image-16224" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/Find-Linux-Uptime.png 718w, https://www.tecmint.com/wp-content/uploads/2015/10/Find-Linux-Uptime-620x296.png 620w" sizes="(max-width: 620px) 100vw, 620px" /></noscript></a><figcaption id="caption-attachment-16224" class="wp-caption-text">tuptime &#8211; Shows Historical and Statistical Running Time of Linux</figcaption></figure>
<p>In this guide, we shall look at a Linux tool called <strong>tuptime</strong> that can help System Administrators to know for how long a Linux machine has been up and running. </p>
<h4>What is tuptime?</h4>
<p><strong>tuptime</strong> is a tool used for reporting the historical and statistical running time (<strong>uptime</strong>) of a Linux system, which keeps it between restarts. This tool works more less like the <strong>uptime</strong> command but though it provides a more advanced output.</p>
<p><strong>This command line tool can:</strong></p>
<ol>
<li>Register used kernels.</li>
<li>Register the first boot time.</li>
<li>Count system startups.</li>
<li>Count good and bad shutdowns.</li>
<li>Calculate uptime and downtime percentage since first boot time.</li>
<li>Calculate the largest, shortest and average uptime and downtime.</li>
<li>Calculate the accumulated system uptime, downtime and total.</li>
<li>Print current uptime.</li>
<li>Print formatted table or list with most of the previous values stored.</li>
</ol>
<h4>Requirements</h4>
<ol>
<li>Linux or FreeBSD OS.</li>
<li>Python 2.7 or 3.x installed but latest version is recommended.</li>
<li>Python modules (sys, os, optparse, sqlite3, datetime, locale, platform, subprocess, time).</li>
</ol>
<h3>How to Install tuptime in Linux</h3>
<p>First you need to clone the repository by running the command below:</p>
<pre>$ git clone https://github.com/rfrail3/tuptime.git
</pre>
<figure id="attachment_16182" aria-describedby="caption-attachment-16182" style="width: 610px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2015/10/Clone-tuptime-Tool.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2015/10/Clone-tuptime-Tool.png" loading="lazy" width="819" height="268" alt="Clone tuptime Tool" class="size-medium wp-image-16182" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/Clone-tuptime-Tool.png 819w, https://www.tecmint.com/wp-content/uploads/2015/10/Clone-tuptime-Tool-620x203.png 620w" sizes="(max-width: 819px) 100vw, 819px"><noscript><img loading="lazy" width="819" height="268" src="https://www.tecmint.com/wp-content/uploads/2015/10/Clone-tuptime-Tool.png" alt="Clone tuptime Tool" class="size-medium wp-image-16182" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/Clone-tuptime-Tool.png 819w, https://www.tecmint.com/wp-content/uploads/2015/10/Clone-tuptime-Tool-620x203.png 620w" sizes="(max-width: 819px) 100vw, 819px" /></noscript></a><figcaption id="caption-attachment-16182" class="wp-caption-text">Clone tuptime Tool</figcaption></figure>
<center style="padding-bottom: 45px;padding-top:35px;"><div align="center" id="tecmint_incontent"><script data-cfasync="false" type="text/javascript">freestar.config.enabled_slots.push({ placementName: "tecmint_incontent", slotId: "tecmint_incontent" });</script></div></center><p>Then move into the <strong>latest</strong> directory inside the <strong>tuptime</strong> directory. Next, copy <strong>tuptime</strong> script inside the <strong>latest</strong> directory to /usr/bin and set executable permission as shown.</p>
<pre>$ cd tuptime/latest 
$ sudo cp tuptime /usr/bin/tuptime
$ sudo chmod ugo+x /usr/bin/tuptime
</pre>
<figure id="attachment_16185" aria-describedby="caption-attachment-16185" style="width: 610px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2015/10/Copy-tuptime.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2015/10/Copy-tuptime.png" loading="lazy" alt="Configure tuptime" width="620" height="117" class="size-medium wp-image-16185" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/Copy-tuptime.png 819w, https://www.tecmint.com/wp-content/uploads/2015/10/Copy-tuptime-620x117.png 620w" sizes="(max-width: 620px) 100vw, 620px"><noscript><img loading="lazy" src="https://www.tecmint.com/wp-content/uploads/2015/10/Copy-tuptime.png" alt="Configure tuptime" width="620" height="117" class="size-medium wp-image-16185" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/Copy-tuptime.png 819w, https://www.tecmint.com/wp-content/uploads/2015/10/Copy-tuptime-620x117.png 620w" sizes="(max-width: 620px) 100vw, 620px" /></noscript></a><figcaption id="caption-attachment-16185" class="wp-caption-text">Configure tuptime</figcaption></figure>
<p>Now, copy the cron file <strong>tuptime/latest/cron.d/tuptime</strong> to <strong>/etc/cron.d/tuptime</strong> and set executable permission as follows.</p>
<pre>$ sudo cp tuptime/latest/cron.d/tuptime /etc/cron.d/tuptime
$ sudo chmod 644 /etc/cron.d/tuptime
</pre>
<figure id="attachment_16186" aria-describedby="caption-attachment-16186" style="width: 610px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2015/10/Configure-tuptime-Cron.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2015/10/Configure-tuptime-Cron-620x41.png" loading="lazy" alt="Configure tuptime Cron" width="620" height="41" class="size-medium wp-image-16186" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/Configure-tuptime-Cron-620x41.png 620w, https://www.tecmint.com/wp-content/uploads/2015/10/Configure-tuptime-Cron-1024x68.png 1024w, https://www.tecmint.com/wp-content/uploads/2015/10/Configure-tuptime-Cron.png 1182w" sizes="(max-width: 620px) 100vw, 620px"><noscript><img loading="lazy" src="https://www.tecmint.com/wp-content/uploads/2015/10/Configure-tuptime-Cron-620x41.png" alt="Configure tuptime Cron" width="620" height="41" class="size-medium wp-image-16186" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/Configure-tuptime-Cron-620x41.png 620w, https://www.tecmint.com/wp-content/uploads/2015/10/Configure-tuptime-Cron-1024x68.png 1024w, https://www.tecmint.com/wp-content/uploads/2015/10/Configure-tuptime-Cron.png 1182w" sizes="(max-width: 620px) 100vw, 620px" /></noscript></a><figcaption id="caption-attachment-16186" class="wp-caption-text">Configure tuptime Cron</figcaption></figure>
<p>If you followed above these steps correctly, then it must be installed on your system at this point.</p>
<h3>How do I use tuptime?</h3>
<p>Next we shall look at how to use this tool for certain system administration activities by running it with different options as a privileged user as shown.</p>
<p><strong>1.</strong> When you run <strong>tuptime</strong> without any options, you get a display screen similar to the one below.</p>
<pre># tuptime
</pre>
<figure id="attachment_16187" aria-describedby="caption-attachment-16187" style="width: 610px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-usage.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-usage-620x313.png" loading="lazy" alt="tuptime in action" width="620" height="313" class="size-medium wp-image-16187" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-usage-620x313.png 620w, https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-usage.png 907w" sizes="(max-width: 620px) 100vw, 620px"><noscript><img loading="lazy" src="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-usage-620x313.png" alt="tuptime in action" width="620" height="313" class="size-medium wp-image-16187" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-usage-620x313.png 620w, https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-usage.png 907w" sizes="(max-width: 620px) 100vw, 620px" /></noscript></a><figcaption id="caption-attachment-16187" class="wp-caption-text">tuptime in action</figcaption></figure>
<p><strong>2.</strong> You can display output with <strong>date</strong> and <strong>time</strong> as follows.</p>
<pre># tuptime --date='%H:%M:%S %d-%m-%Y'
</pre>
<figure id="attachment_16188" aria-describedby="caption-attachment-16188" style="width: 610px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-date-and-time.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-date-and-time-620x313.png" loading="lazy" alt="tuptime date and time" width="620" height="313" class="size-medium wp-image-16188" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-date-and-time-620x313.png 620w, https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-date-and-time.png 907w" sizes="(max-width: 620px) 100vw, 620px"><noscript><img loading="lazy" src="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-date-and-time-620x313.png" alt="tuptime date and time" width="620" height="313" class="size-medium wp-image-16188" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-date-and-time-620x313.png 620w, https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-date-and-time.png 907w" sizes="(max-width: 620px) 100vw, 620px" /></noscript></a><figcaption id="caption-attachment-16188" class="wp-caption-text">tuptime date and time</figcaption></figure>
<p><strong>3.</strong> To print system life as a list, you can run this command below:</p>
<pre># tuptime --list
</pre>
<figure id="attachment_16189" aria-describedby="caption-attachment-16189" style="width: 589px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Uptime.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Uptime.png" loading="lazy" alt="Check Linux Uptime" width="599" height="135" class="size-full wp-image-16189"><noscript><img loading="lazy" src="https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Uptime.png" alt="Check Linux Uptime" width="599" height="135" class="size-full wp-image-16189" /></noscript></a><figcaption id="caption-attachment-16189" class="wp-caption-text">Check Linux Uptime</figcaption></figure>
<p><strong>4.</strong> You can create an alternative database file as follows. The database will be created in a SQLite format.</p>
<pre># tuptime --filedb /tmp/tuptime_testdb.db
</pre>
<figure id="attachment_16190" aria-describedby="caption-attachment-16190" style="width: 610px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-dump-output.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-dump-output-620x356.png" loading="lazy" alt="tuptime Database" width="620" height="356" class="size-medium wp-image-16190" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-dump-output-620x356.png 620w, https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-dump-output.png 929w" sizes="(max-width: 620px) 100vw, 620px"><noscript><img loading="lazy" src="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-dump-output-620x356.png" alt="tuptime Database" width="620" height="356" class="size-medium wp-image-16190" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-dump-output-620x356.png 620w, https://www.tecmint.com/wp-content/uploads/2015/10/tuptime-dump-output.png 929w" sizes="(max-width: 620px) 100vw, 620px" /></noscript></a><figcaption id="caption-attachment-16190" class="wp-caption-text">tuptime Database</figcaption></figure>
<p><strong>5.</strong> To order output information by end state of poweroff run this command.</p>
<pre># tuptime --end --table
</pre>
<figure id="attachment_16191" aria-describedby="caption-attachment-16191" style="width: 610px" class="wp-caption aligncenter"><a href="https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Last-Shutdown.png"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Last-Shutdown-620x61.png" loading="lazy" alt="Check Linux Last Shutdown" width="620" height="61" class="size-medium wp-image-16191" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Last-Shutdown-620x61.png 620w, https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Last-Shutdown-1024x101.png 1024w, https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Last-Shutdown.png 1232w" sizes="(max-width: 620px) 100vw, 620px"><noscript><img loading="lazy" src="https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Last-Shutdown-620x61.png" alt="Check Linux Last Shutdown" width="620" height="61" class="size-medium wp-image-16191" srcset="https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Last-Shutdown-620x61.png 620w, https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Last-Shutdown-1024x101.png 1024w, https://www.tecmint.com/wp-content/uploads/2015/10/Check-Linux-Last-Shutdown.png 1232w" sizes="(max-width: 620px) 100vw, 620px" /></noscript></a><figcaption id="caption-attachment-16191" class="wp-caption-text">Check Linux Last Shutdown</figcaption></figure>
<p>Some other options used with the <strong>tuptime</strong> tool as follows:</p>
<ol>
<li>To print the system kernel version in the output, use the <code>--kernel</code> option.</li>
<li>To register a gracefully system shutdown, use the <code>--gracefully</code> option. It allows you to know whether the system shutdown was good or bad.</li>
<li>To display output after a given number of seconds and epoch, use the <code>--seconds</code> option.</li>
<li>You can also order output information by offtime or downtime by using the &#8211;offtime option. Use this option with <code>--time</code> or <code>--list</code>.</li>
<li>To print detailed output information while running the command, use <code>--verbose</code> option.</li>
<li>You can view help information by using <code>--help</code> option and <code>--version</code> to print the version of tuptime you are using.</li>
</ol>
<h3>Summary</h3>
<p>In this article, we have looked at ways of using <strong>tuptime</strong> command for System Administration activities. This command is simple to use and if you do not understand any point in the guide, you can post a comment or add more information what I have put together. Remember to stay connected to Tecmint.</p>
<p><strong>References</strong>: <a rel="nofollow" href="https://github.com/rfrail3/tuptime" target="_blank">tuptime home page</a></p>
</div><!-- .entry-content -->
<footer class="entry-meta">
<span class="tags-links"><span class="screen-reader-text">Tags </span><a href="https://www.tecmint.com/tag/commandline-tools/" rel="tag">commandline tools</a></span> 		<nav id="nav-below" class="post-navigation">
<span class="screen-reader-text">Post navigation</span>
<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.tecmint.com/install-zabbix-agent-and-add-windows-host-to-zabbix-monioring/" rel="prev">How to Install Zabbix Agent and Add Windows Host to Zabbix Monitoring &#8211; Part 4</a></span></div><div class="nav-next"><span class="next" title="Next"><a href="https://www.tecmint.com/install-and-configure-django-web-framework-in-centos-debian-ubuntu/" rel="next">Installing and Configuring Django Web Framework with Virtual Environments in CentOS/Debian &#8211; Part 1</a></span></div>		</nav><!-- #nav-below -->
</footer><!-- .entry-meta -->
<div class="alertbox">If you liked this article, then do <a style="text-decoration:underline;color:bb0e30;" rel="nofollow" target="_blank" href="https://newsletter.tecmint.com/subscription?f=hj6Ohm9gck3Z0PQ2BBBTh892iaCbDV3jJJa3hD8ULUlubOgnbo8aF44vt2HZfdc36g">subscribe to email alerts</a> for Linux tutorials. If you have any questions or doubts? do <a style="text-decoration:underline;color:bb0e30;" href="https://www.tecmint.com/find-linux-uptime-shutdown-and-reboot-time-with-tuptime/#respond">ask for help in the comments</a> section.</div>
<center style="padding-bottom:20px;padding-top:40px;">
<!-- Tag ID: tecmint_incontent_2 -->
<div align="center" id="tecmint_incontent_2">
<script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_incontent_2", slotId: "tecmint_incontent_2" });
</script>
</div>
</center>
<div class="after-post-box">
<h2>If You Appreciate What We Do Here On TecMint, You Should Consider:</h2>
<p>TecMint is the fastest growing and most trusted community site for any kind of Linux Articles, Guides and Books on the web. Millions of people visit TecMint! to search or browse the thousands of published articles available FREELY to all.</p>
<p>If you like what you are reading, please consider buying us a coffee ( or 2 ) as a token of appreciation.</p>
<p align="center"><a href="https://www.buymeacoffee.com/tecmint" rel="nofollow" target="_blank"><img alt="Support Us" src="https://www.tecmint.com/wp-content/uploads/2015/01/coffee.png" alt="Coffee"></a></p>
<p style="text-align: center;"><strong style=" color:#fe3300;font-size:20px;">We are thankful for your never ending support.</strong></p>
</div>
<div class="wpsp-related-posts  grid-container">
<h2>Related Posts</h2>
<style>.wp-show-posts-columns#wpsp-38213 {margin-left: -2em; }.wp-show-posts-columns#wpsp-38213 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-38213" class=" wp-show-posts-columns wp-show-posts" style=""><article class=" wp-show-posts-single post-841 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands category-networking-commands wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/12-tcpdump-commands-a-network-sniffer-tool/"  title="12 Tcpdump Commands &#8211; A Network Sniffer Tool"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2012/08/Tcpdump-Commands.png" width="425" height="276" class="attachment-full size-full wp-post-image" alt="Linux tcpdump command examples" loading="lazy" itemprop="image" srcset="https://www.tecmint.com/wp-content/uploads/2012/08/Tcpdump-Commands.png 425w, https://www.tecmint.com/wp-content/uploads/2012/08/Tcpdump-Commands-300x194.png 300w" sizes="(max-width: 425px) 100vw, 425px"><noscript><img width="425" height="276" src="https://www.tecmint.com/wp-content/uploads/2012/08/Tcpdump-Commands.png" class="attachment-full size-full wp-post-image" alt="Linux tcpdump command examples" loading="lazy" itemprop="image" srcset="https://www.tecmint.com/wp-content/uploads/2012/08/Tcpdump-Commands.png 425w, https://www.tecmint.com/wp-content/uploads/2012/08/Tcpdump-Commands-300x194.png 300w" sizes="(max-width: 425px) 100vw, 425px" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/12-tcpdump-commands-a-network-sniffer-tool/" rel="bookmark">12 Tcpdump Commands &#8211; A Network Sniffer Tool</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-18279 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/find-top-large-directories-and-files-sizes-in-linux/"  title="How to Find Out Top Directories and Files (Disk Space) in Linux"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2016/01/Find-Largest-Files-Directories-Size-in-Linux.png" width="720" height="345" class="attachment-full size-full wp-post-image" alt="Find Largest Files and Directories Size in Linux" loading="lazy" itemprop="image"><noscript><img width="720" height="345" src="https://www.tecmint.com/wp-content/uploads/2016/01/Find-Largest-Files-Directories-Size-in-Linux.png" class="attachment-full size-full wp-post-image" alt="Find Largest Files and Directories Size in Linux" loading="lazy" itemprop="image" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/find-top-large-directories-and-files-sizes-in-linux/" rel="bookmark">How to Find Out Top Directories and Files (Disk Space) in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-2991 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/useful-linux-commands-for-newbies/"  title="20 Commands for Newbies Who Switched from Windows to Linux"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2013/05/Linux-Basic-Commands.jpg" width="720" height="345" class="attachment-full size-full wp-post-image" alt="Linux Basic Commands" loading="lazy" itemprop="image" srcset="https://www.tecmint.com/wp-content/uploads/2013/05/Linux-Basic-Commands.jpg 720w, https://www.tecmint.com/wp-content/uploads/2013/05/Linux-Basic-Commands-620x297.jpg 620w" sizes="(max-width: 720px) 100vw, 720px"><noscript><img width="720" height="345" src="https://www.tecmint.com/wp-content/uploads/2013/05/Linux-Basic-Commands.jpg" class="attachment-full size-full wp-post-image" alt="Linux Basic Commands" loading="lazy" itemprop="image" srcset="https://www.tecmint.com/wp-content/uploads/2013/05/Linux-Basic-Commands.jpg 720w, https://www.tecmint.com/wp-content/uploads/2013/05/Linux-Basic-Commands-620x297.jpg 620w" sizes="(max-width: 720px) 100vw, 720px" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/useful-linux-commands-for-newbies/" rel="bookmark">20 Commands for Newbies Who Switched from Windows to Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-4182 post type-post status-publish format-standard has-post-thumbnail hentry category-commandline-tools category-linux-commands tag-linux-kill-command-examples wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/how-to-kill-a-process-in-linux/"  title="How to Kill Linux Process Using Kill, Pkill and Killall"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2013/09/Linux-kill-Commands.jpg" width="720" height="345" class="attachment-full size-full wp-post-image" alt="Kill Command Examples" loading="lazy" itemprop="image" srcset="https://www.tecmint.com/wp-content/uploads/2013/09/Linux-kill-Commands.jpg 720w, https://www.tecmint.com/wp-content/uploads/2013/09/Linux-kill-Commands-620x297.jpg 620w" sizes="(max-width: 720px) 100vw, 720px"><noscript><img width="720" height="345" src="https://www.tecmint.com/wp-content/uploads/2013/09/Linux-kill-Commands.jpg" class="attachment-full size-full wp-post-image" alt="Kill Command Examples" loading="lazy" itemprop="image" srcset="https://www.tecmint.com/wp-content/uploads/2013/09/Linux-kill-Commands.jpg 720w, https://www.tecmint.com/wp-content/uploads/2013/09/Linux-kill-Commands-620x297.jpg 620w" sizes="(max-width: 720px) 100vw, 720px" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/how-to-kill-a-process-in-linux/" rel="bookmark">How to Kill Linux Process Using Kill, Pkill and Killall</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-4386 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/screen-command-examples-to-manage-linux-terminals/"  title="10 Screen Command Examples to Manage Linux Terminals"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2013/10/Screen-Command-Examples.jpg" width="720" height="345" class="attachment-full size-full wp-post-image" alt="Linux Screen Command Examples" loading="lazy" itemprop="image" srcset="https://www.tecmint.com/wp-content/uploads/2013/10/Screen-Command-Examples.jpg 720w, https://www.tecmint.com/wp-content/uploads/2013/10/Screen-Command-Examples-620x297.jpg 620w" sizes="(max-width: 720px) 100vw, 720px"><noscript><img width="720" height="345" src="https://www.tecmint.com/wp-content/uploads/2013/10/Screen-Command-Examples.jpg" class="attachment-full size-full wp-post-image" alt="Linux Screen Command Examples" loading="lazy" itemprop="image" srcset="https://www.tecmint.com/wp-content/uploads/2013/10/Screen-Command-Examples.jpg 720w, https://www.tecmint.com/wp-content/uploads/2013/10/Screen-Command-Examples-620x297.jpg 620w" sizes="(max-width: 720px) 100vw, 720px" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/screen-command-examples-to-manage-linux-terminals/" rel="bookmark">10 Screen Command Examples to Manage Linux Terminals</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-936 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-cat-command-examples wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">		<div class="wp-show-posts-image  wpsp-image-center ">
<a href="https://www.tecmint.com/13-basic-cat-command-examples-in-linux/"  title="13 Basic Cat Command Examples in Linux"><img src="https://www.tecmint.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.tecmint.com/wp-content/uploads/2012/08/Linux-Cat-Commands.png" width="300" height="194" class="attachment-full size-full wp-post-image" alt="Linux Cat Command" loading="lazy" itemprop="image"><noscript><img width="300" height="194" src="https://www.tecmint.com/wp-content/uploads/2012/08/Linux-Cat-Commands.png" class="attachment-full size-full wp-post-image" alt="Linux Cat Command" loading="lazy" itemprop="image" /></noscript></a>		</div>
<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/13-basic-cat-command-examples-in-linux/" rel="bookmark">13 Basic Cat Command Examples in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --></article><div class="wpsp-clear"></div></section><!-- .wp-show-posts --></div>	</div><!-- .inside-article -->
</article><!-- #post-## -->
<div class="comments-area">
<div id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Got something to say? Join the discussion. <small><a rel="nofollow" id="cancel-comment-reply-link" href="/find-linux-uptime-shutdown-and-reboot-time-with-tuptime/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.tecmint.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p>
Have a question or suggestion? Please leave a comment to start the discussion. Please keep in mind that all comments are moderated and your email address will NOT be published.
</p><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" />
<label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30" />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class='comment-form-subscriptions'><label for='subscribe-reloaded'><input style='width:30px' type='checkbox' name='subscribe-reloaded' id='subscribe-reloaded' value='yes' /> Notify me of followup comments via e-mail. You can also <a href='https://www.tecmint.com/comment-subscriptions/?srp=16181&amp;srk=0b81c0e99cc43eb9ade2ba1b6ab240b4&amp;sra=s&amp;srsrc=f'>subscribe</a> without commenting.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='16181' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7384bf01b6" /></p><input type="hidden" id="ak_js" name="ak_js" value="180"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->
</div>
</main><!-- #main -->
</div><!-- #primary -->
<div id="right-sidebar" class="widget-area grid-25 tablet-grid-25 grid-parent sidebar" itemtype="https://schema.org/WPSideBar" itemscope>
<div class="inside-right-sidebar">
<aside id="custom_html-10" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<div class="socialprofiles">
<p style="font-weight:800;color:#c33;font-size:20px;">Over 3,500,000+ Readers</p>
<a href="https://www.facebook.com/TecMint" target="_blank" rel="nofollow noopener noreferrer" title="Join TecMint on Facebook"><img alt="Join TecMint on Facebook" src="https://www.tecmint.com/wp-content/themes/tecmint/images/facebook.png"></a>
<a href="https://twitter.com/tecmint" target="_blank" rel="nofollow noopener noreferrer" title="Follow TecMint on Twitter"><img alt="Follow TecMint on Twitter" src="https://www.tecmint.com/wp-content/themes/tecmint/images/twitter.png"></a>
<a href="https://www.linkedin.com/company/tecmint" target="_blank" rel="nofollow noopener noreferrer" title="Join TecMint on LinkedIn"><img alt="Join TecMint on LinkedIn" src="https://www.tecmint.com/wp-content/themes/tecmint/images/linkedin.png"></a>
<a href="https://instagram.com/tecmint" target="_blank" rel="nofollow noopener noreferrer" title="Follow TecMint on Instagram"><img alt="Follow TecMint on Instagram" src="https://www.tecmint.com/wp-content/themes/tecmint/images/instagram.png"></a>
<a href="https://feedly.com/i/subscription/feed/https://www.tecmint.com/feed/" target="_blank" rel="nofollow noopener noreferrer" title="Follow TecMint via RSS Feed"><img alt="Follow TecMint via RSS Feed" src="https://www.tecmint.com/wp-content/themes/tecmint/images/rss.png"></a>
<a href="https://newsletter.tecmint.com/subscription?f=hj6Ohm9gck3Z0PQ2BBBTh892iaCbDV3jJJa3hD8ULUlubOgnbo8aF44vt2HZfdc36g" target="_blank" rel="nofollow noopener noreferrer" title="Subscribe to TecMint Newsletter"><img alt="Subscribe to TecMint Newsletter" src="https://www.tecmint.com/wp-content/themes/tecmint/images/newsletter.png"></a>
</div></center></div></aside><aside id="custom_html-9" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<!-- Tag ID: tecmint_right_rail_1 -->
<div align="center" id="tecmint_right_rail_1">
<script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_right_rail_1", slotId: "tecmint_right_rail_1" });
</script>
</div>
</center></div></aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a style="color: #c33;font-weight:700; text-align: center;    display: inline-block;text-decoration: underline;" href="https://www.tecmint.com/free-online-linux-learning-guide-for-beginners/" target="_blank" rel="noopener">A Beginners Guide To Learn Linux  for Free [with Examples]</a></div></aside><aside id="custom_html-4" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<!-- Tag ID: tecmint_right_rail_2 -->
<div align="center" id="tecmint_right_rail_2">
<script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_right_rail_2", slotId: "tecmint_right_rail_2" });
</script>
</div>
</center></div></aside><aside id="custom_html-5" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a style="color: #c33;font-weight:700; text-align: center;    display: inline-block;text-decoration: underline;" href="https://www.tecmint.com/red-hat-rhcsa-rhce-exam-certification-book/" target="_blank" rel="noopener">Red Hat RHCSA/RHCE 8 Certification Study Guide [eBooks]</a></div></aside><aside id="custom_html-6" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a style="color: #c33;font-weight:700; text-align: center;    display: inline-block;text-decoration: underline;" href="https://www.tecmint.com/linux-foundation-lfcs-lfce-certification-exam-book/" target="_blank" rel="noopener">Linux Foundation LFCS and LFCE Certification Study Guide [eBooks]</a></div></aside><aside id="custom_html-7" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<!-- Tag ID: tecmint_right_rail_3 -->
<div id="tecmint_right_rail_3" align="center"><script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_right_rail_3", slotId: "tecmint_right_rail_3" });
</script></div>
</center></div></aside><aside id="wpsp_widget-2" class="widget inner-padding widget_wpsp_widget"><h2 class="widget-title">Learn Linux Commands and Tools</h2><style>.wp-show-posts-columns#wpsp-38336 {margin-left: -2em; }.wp-show-posts-columns#wpsp-38336 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-38336" class=" wp-show-posts" style=""><article class=" wp-show-posts-single wpsp-clearfix post-30683 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands category-monitoring-tools tag-fsck-command-examples tag-linux-filesystem-repair" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/fsck-repair-file-system-errors-in-linux/" rel="bookmark">How to Use &#8216;fsck&#8217; to Repair File System Errors in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-22055 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-at-command-usage tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/linux-cron-alternative-at-command-to-schedule-tasks/" rel="bookmark">How to Use &#8216;at&#8217; Command to Schedule a Task on Given or Later Time in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-13515 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-commands-2" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/clear-ram-memory-cache-buffer-and-swap-space-on-linux/" rel="bookmark">How to Clear RAM Memory Cache, Buffer and Swap Space on Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-15644 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/manage-file-types-and-set-system-time-in-linux/" rel="bookmark">5 Useful Commands to Manage File Types and System Time in Linux &#8211; Part 3</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-18010 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks tag-tar-command-examples" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/extract-tar-files-to-specific-or-different-directory-in-linux/" rel="bookmark">How to Extract Tar Files to Specific or Different Directory in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-30484 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-commandline-tools tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/find-files-quickly-in-linux-terminal/" rel="bookmark">5 Command Line Tools to Find Files Quickly in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article></section><!-- .wp-show-posts --></aside><aside id="custom_html-11" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><center>
<a rel="nofollow noopener" target="_blank" href="https://newsletter.tecmint.com/subscription?f=hj6Ohm9gck3Z0PQ2BBBTh892iaCbDV3jJJa3hD8ULUlubOgnbo8aF44vt2HZfdc36g"><img alt="Join TecMint Weekly Newsletter" src="https://www.tecmint.com/wp-content/uploads/2020/07/Tecmint-Email-Newsletter-Signup.png"/></a>
</center>
<p style="text-align:center;border-top: 2px dashed #8e8e8e;margin-top: 10px;padding-top: 10px;">If You Appreciate What We Do Here On TecMint, You Should Consider:</p>
<p align="center"><a href="https://www.buymeacoffee.com/tecmint" rel="nofollow noopener" target="_blank"><img alt="Support Us" src="https://www.tecmint.com/wp-content/uploads/2015/01/coffee.png"></a></p></div></aside>	</div><!-- .inside-right-sidebar -->
</div><!-- #secondary -->

</div><!-- #content -->
</div><!-- #page -->
<center style="padding-top:10px;padding-bottom:30px;">
<!-- Tag ID: tecmint_leaderboard_btf -->
<div id="tecmint_leaderboard_btf" align="center"><script data-cfasync="false" type="text/javascript">
freestar.config.enabled_slots.push({ placementName: "tecmint_leaderboard_btf", slotId: "tecmint_leaderboard_btf" });
</script></div>
</center>
<div class="site-footer footer-bar-active footer-bar-align-center">
<div id="footer-widgets" class="site footer-widgets">
<div class="footer-widgets-container grid-container grid-parent">
<div class="inside-footer-widgets">
<div class="footer-widget-1 grid-parent grid-33 tablet-grid-50 mobile-grid-100">
<aside id="wpsp_widget-3" class="widget inner-padding widget_wpsp_widget"><h2 class="widget-title">Linux Server Monitoring Tools</h2><style>.wp-show-posts-columns#wpsp-38337 {margin-left: -2em; }.wp-show-posts-columns#wpsp-38337 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-38337" class=" wp-show-posts" style=""><article class=" wp-show-posts-single wpsp-clearfix post-25659 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools tag-linux-monitoring" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/linfo-shows-linux-server-health-status-in-real-time/" rel="bookmark">Linfo &#8211; Shows Linux Server Health Status in Real-Time</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-33110 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools category-redhat tag-nagios-monitoring tag-rhel-8" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/install-nagios-on-rhel-8/" rel="bookmark">How to Install Nagios Monitoring Tool on RHEL 8</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-35990 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools category-ubuntu tag-linux-network-monitoring tag-linux-server-monitoring tag-ubuntu-tips" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/install-pandora-fms-in-ubuntu/" rel="bookmark">How To Install Pandora FMS Monitoring Tool in Ubuntu 18.04</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-25275 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools tag-linux-monitoring" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/pydash-a-web-based-linux-performance-monitoring-tool/" rel="bookmark">pyDash &#8211; A Web Based Linux Performance Monitoring Tool</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-22926 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools tag-linux-monitoring" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/cockpit-monitor-multiple-linux-servers-via-web-browser/" rel="bookmark">Cockpit &#8211; A Powerful Tool to Monitor and Administer Multiple Linux Servers Using a Web Browser</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-25769 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools tag-commandline-tools tag-linux-monitoring" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/check-linux-cpu-information/" rel="bookmark">9 Useful Commands to Get CPU Information on Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article></section><!-- .wp-show-posts --></aside>	</div>
<div class="footer-widget-2 grid-parent grid-33 tablet-grid-50 mobile-grid-100">
<aside id="wpsp_widget-4" class="widget inner-padding widget_wpsp_widget"><h2 class="widget-title">Learn Linux Tricks &#038; Tips</h2><style>.wp-show-posts-columns#wpsp-38338 {margin-left: -2em; }.wp-show-posts-columns#wpsp-38338 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-38338" class=" wp-show-posts" style=""><article class=" wp-show-posts-single wpsp-clearfix post-24373 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/create-a-shared-directory-in-linux/" rel="bookmark">How to Create a Shared Directory for All Users in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-27288 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-commandline-tools tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/find-user-account-info-and-login-details-in-linux/" rel="bookmark">11 Ways to Find User Account Info and Login Details in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-28197 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/clear-command-line-history-in-linux/" rel="bookmark">How to Clear BASH Command Line History in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-19885 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/backup-or-clone-linux-partitions-using-cat-command/" rel="bookmark">How to Backup or Clone Linux Partitions Using &#8216;cat&#8217; Command</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-13593 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/useful-linux-hacks-commands/" rel="bookmark">3 Useful Hacks Every Linux User Must Know</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-17471 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux-tricks" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/delete-remove-a-user-account-with-home-directory-in-linux/" rel="bookmark">How to Delete User Accounts with Home Directory in Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article></section><!-- .wp-show-posts --></aside>	</div>
<div class="footer-widget-3 grid-parent grid-33 tablet-grid-50 mobile-grid-100">
<aside id="wpsp_widget-5" class="widget inner-padding widget_wpsp_widget"><h2 class="widget-title">Best Linux Tools</h2><style>.wp-show-posts-columns#wpsp-38100 {margin-left: -2em; }.wp-show-posts-columns#wpsp-38100 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-38100" class=" wp-show-posts" style=""><article class=" wp-show-posts-single wpsp-clearfix post-23795 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools tag-best-linux-tools tag-open-source-tools" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/best-free-open-source-tools-for-linux/" rel="bookmark">10 Best Free and Open Source Software (FOSS) Programs I Found in 2020</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-19527 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools tag-linux-audio-editors" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/free-music-creation-or-audio-editing-softwares-for-linux/" rel="bookmark">16 Best Open Source Music Making Software for Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-21929 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools tag-linux-calendar-apps" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/best-calendar-apps-linux-desktop/" rel="bookmark">7 Best Calendar Apps for Linux Desktop in 2020</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-24950 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools tag-best-linux-tools" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/best-pdf-page-cropping-tools-for-linux/" rel="bookmark">6 Best PDF Page Cropping Tools For Linux</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-22177 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools tag-linux-twitter-clients" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/best-linux-twitter-clients/" rel="bookmark">9 Best Twitter Clients for Linux That You Will Love to Use</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article><article class=" wp-show-posts-single wpsp-clearfix post-19665 post type-post status-publish format-standard has-post-thumbnail hentry category-top-tools tag-pdf-viewers" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style="">						<header class="wp-show-posts-entry-header">
<p class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.tecmint.com/linux-pdf-viewers-and-readers-tools/" rel="bookmark">8 Best PDF Document Viewers for Linux Systems</a></p>						</header><!-- .entry-header -->
</div><!-- wp-show-posts-inner --><div class="wpsp-clear"></div></article></section><!-- .wp-show-posts --></aside>	</div>
</div>
</div>
</div>
<footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope>
<div class="inside-site-info grid-container grid-parent">
<div class="footer-bar">
<aside id="nav_menu-2" class="widget inner-padding widget_nav_menu"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-18572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18572"><a href="https://www.tecmint.com/donate-to-tecmint/">Donate to TecMint</a></li>
<li id="menu-item-10437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10437"><a href="https://www.tecmint.com/contact-us/">Contact Us</a></li>
<li id="menu-item-10442" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10442"><a href="https://www.tecmint.com/advertise/">Advertise on TecMint</a></li>
<li id="menu-item-10441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10441"><a href="https://www.tecmint.com/services/">Linux Services</a></li>
<li id="menu-item-10435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10435"><a href="https://www.tecmint.com/copyright-policy/">Copyright Policy</a></li>
<li id="menu-item-10436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10436"><a href="https://www.tecmint.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-13339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13339"><a href="https://www.tecmint.com/career/">Career</a></li>
<li id="menu-item-24288" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24288"><a href="https://www.tecmint.com/sponsored-post-guidelines-tecmint/">Sponsored Post</a></li>
</ul></div></aside>		</div>
<div class="copyright-bar">
Tecmint: Linux Howtos, Tutorials &amp; Guides &copy; 2021. All Rights Reserved.
<p>The material in this site cannot be republished either online or offline, without our permission.</p>
<p>Hosting Sponsored by : <a style="font-weight:bold;color:yellow" href="https://linode.gvw92c.net/tecmint" target="_blank" rel="nofollow">Linode Cloud Hosting</a></p>				</div>
</div>
</footer><!-- .site-info -->
</div><!-- .site-footer -->
<a title="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
<span class="screen-reader-text">Scroll back to top</span>
</a><div class="wplogout-float-social-wrapper hide-on-mobile hide-on-tablet">
<a class="wplogout-float-social-sharing wplogout-social-facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tecmint.com%2Ffind-linux-uptime-shutdown-and-reboot-time-with-tuptime%2F" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"/></svg></a>
<a class="wplogout-float-social-sharing wplogout-social-twitter" href="https://twitter.com/intent/tweet?text=tuptime+%26%238211%3B+Shows+Historical+and+Statistical+Running+Time+of+Linux+Systems&amp;url=https%3A%2F%2Fwww.tecmint.com%2Ffind-linux-uptime-shutdown-and-reboot-time-with-tuptime%2F&amp;via=tecmint" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"/></svg></a>
<a class="wplogout-float-social-sharing wplogout-social-linkedin" href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.tecmint.com%2Ffind-linux-uptime-shutdown-and-reboot-time-with-tuptime%2F&amp;title=tuptime+%26%238211%3B+Shows+Historical+and+Statistical+Running+Time+of+Linux+Systems&amp;mini=true" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"/></svg></a>
<a class="wplogout-float-social-sharing wplogout-social-reddit" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.tecmint.com%2Ffind-linux-uptime-shutdown-and-reboot-time-with-tuptime%2F&title=tuptime+%26%238211%3B+Shows+Historical+and+Statistical+Running+Time+of+Linux+Systems" target="_blank" rel="nofollow"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24"><path d="M24 11.779c0-1.459-1.192-2.645-2.657-2.645-.715 0-1.363.286-1.84.746-1.81-1.191-4.259-1.949-6.971-2.046l1.483-4.669 4.016.941-.006.058c0 1.193.975 2.163 2.174 2.163 1.198 0 2.172-.97 2.172-2.163s-.975-2.164-2.172-2.164c-.92 0-1.704.574-2.021 1.379l-4.329-1.015c-.189-.046-.381.063-.44.249l-1.654 5.207c-2.838.034-5.409.798-7.3 2.025-.474-.438-1.103-.712-1.799-.712-1.465 0-2.656 1.187-2.656 2.646 0 .97.533 1.811 1.317 2.271-.052.282-.086.567-.086.857 0 3.911 4.808 7.093 10.719 7.093s10.72-3.182 10.72-7.093c0-.274-.029-.544-.075-.81.832-.447 1.405-1.312 1.405-2.318zm-17.224 1.816c0-.868.71-1.575 1.582-1.575.872 0 1.581.707 1.581 1.575s-.709 1.574-1.581 1.574-1.582-.706-1.582-1.574zm9.061 4.669c-.797.793-2.048 1.179-3.824 1.179l-.013-.003-.013.003c-1.777 0-3.028-.386-3.824-1.179-.145-.144-.145-.379 0-.523.145-.145.381-.145.526 0 .65.647 1.729.961 3.298.961l.013.003.013-.003c1.569 0 2.648-.315 3.298-.962.145-.145.381-.144.526 0 .145.145.145.379 0 .524zm-.189-3.095c-.872 0-1.581-.706-1.581-1.574 0-.868.709-1.575 1.581-1.575s1.581.707 1.581 1.575-.709 1.574-1.581 1.574z"/></svg></a>
</div><!-- Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<script type="text/javascript" async=true>
(function() {
var host = window.location.hostname;
var element = document.createElement('script');
var firstScript = document.getElementsByTagName('script')[0];
var url = 'https://quantcast.mgr.consensu.org'
.concat('/choice/', 'XaecbbMz6DF2q', '/', host, '/choice.js')
var uspTries = 0;
var uspTriesLimit = 3;
element.async = true;
element.type = 'text/javascript';
element.src = url;
firstScript.parentNode.insertBefore(element, firstScript);
function makeStub() {
var TCF_LOCATOR_NAME = '__tcfapiLocator';
var queue = [];
var win = window;
var cmpFrame;
function addFrame() {
var doc = win.document;
var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);
if (!otherCMP) {
if (doc.body) {
var iframe = doc.createElement('iframe');
iframe.style.cssText = 'display:none';
iframe.name = TCF_LOCATOR_NAME;
doc.body.appendChild(iframe);
} else {
setTimeout(addFrame, 5);
}
}
return !otherCMP;
}
function tcfAPIHandler() {
var gdprApplies;
var args = arguments;
if (!args.length) {
return queue;
} else if (args[0] === 'setGdprApplies') {
if (
args.length > 3 &&
args[2] === 2 &&
typeof args[3] === 'boolean'
) {
gdprApplies = args[3];
if (typeof args[2] === 'function') {
args[2]('set', true);
}
}
} else if (args[0] === 'ping') {
var retr = {
gdprApplies: gdprApplies,
cmpLoaded: false,
cmpStatus: 'stub'
};
if (typeof args[2] === 'function') {
args[2](retr);
}
} else {
queue.push(args);
}
}
function postMessageEventHandler(event) {
var msgIsString = typeof event.data === 'string';
var json = {};
try {
if (msgIsString) {
json = JSON.parse(event.data);
} else {
json = event.data;
}
} catch (ignore) {}
var payload = json.__tcfapiCall;
if (payload) {
window.__tcfapi(
payload.command,
payload.version,
function(retValue, success) {
var returnMsg = {
__tcfapiReturn: {
returnValue: retValue,
success: success,
callId: payload.callId
}
};
if (msgIsString) {
returnMsg = JSON.stringify(returnMsg);
}
event.source.postMessage(returnMsg, '*');
},
payload.parameter
);
}
}
while (win) {
try {
if (win.frames[TCF_LOCATOR_NAME]) {
cmpFrame = win;
break;
}
} catch (ignore) {}
if (win === window.top) {
break;
}
win = win.parent;
}
if (!cmpFrame) {
addFrame();
win.__tcfapi = tcfAPIHandler;
win.addEventListener('message', postMessageEventHandler, false);
}
};
makeStub();
var uspStubFunction = function() {
var arg = arguments;
if (typeof window.__uspapi !== uspStubFunction) {
setTimeout(function() {
if (typeof window.__uspapi !== 'undefined') {
window.__uspapi.apply(window.__uspapi, arg);
}
}, 500);
}
};
var checkIfUspIsReady = function() {
uspTries++;
if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
console.warn('USP is not accessible');
} else {
clearInterval(uspInterval);
}
};
if (typeof window.__uspapi === 'undefined') {
window.__uspapi = uspStubFunction;
var uspInterval = setInterval(checkIfUspIsReady, 6000);
}
})();
</script>
<!-- End Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) --><script type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/light/js/jquery.fancybox.pack.js?ver=5.8' id='fancybox-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/light/js/light.js?ver=5.8' id='fancybox-load-js'></script>
<!--[if lte IE 11]>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/themes/tecmint/js/classList.min.js?ver=2.4.2' id='generate-classlist-js'></script>
<![endif]-->
<script type='text/javascript' src='https://www.tecmint.com/wp-content/themes/tecmint/js/menu.min.js?ver=2.4.2' id='generate-menu-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/themes/tecmint/js/a11y.min.js?ver=2.4.2' id='generate-a11y-js'></script>
<script type='text/javascript' id='generate-navigation-search-js-extra'>
/* <![CDATA[ */
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/themes/tecmint/js/navigation-search.min.js?ver=2.4.2' id='generate-navigation-search-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/themes/tecmint/js/back-to-top.min.js?ver=2.4.2' id='generate-back-to-top-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-includes/js/comment-reply.min.js?ver=5.8' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1' id='jquery-sonar-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1' id='wpcom-lazy-load-images-js'></script>
<script type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/wp-show-posts/js/jquery.matchHeight.js?ver=1.1.3' id='wpsp-matchHeight-js'></script>
<script defer type='text/javascript' src='https://www.tecmint.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.11' id='akismet-form-js'></script>
</body>
</html><!-- WP Fastest Cache file was created in 0.38298797607422 seconds, on 02-09-21 13:48:46 -->